Announcement

Collapse
No announcement yet.

Loading program/uSD card issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Loading program/uSD card issue

    Having recently acquired everything I need to program the uLCD-32PT I have, I tried a simple 'display button' program created by dropping the code produced by a button into the main function in the program, compiling and downloading.

    Nothing shows up, ever, and occasionally it'll ask me to put the program on a uSD card.
    I've tried the testButtons program, and it works, but that's written in Designer.

    I'm sure it's a real newb problem, but I can't work out why I can't get such a simple bit of code (provided by the manufacturer!) to do anything.

  • #2


    Please ensure that the uSD card is FAT16 (or FAT) formatted and that it supports SPI mode (easier said than done).

    If the card is definitely formatted correctly please try a different card (preferably a different brand).

    (The testButtons program, as you probably noticed, does not use the uSD card)
    Mark

    Comment


    • #3


      Ah, right. I'd found so little information pertaining to the use of uSD cards on datasheets etc (and it all said they were optional and used for data/user-made graphics storage) that I'd assumed I wouldn't need one for manufacturer-provided graphics.

      Thanks for the info.

      Comment


      • #4


        I have a card, it's plugged in... but Workshop has now completely stopped asking for an SD card. Is there anyway to reset this so it starts asking again?
        Or, would it be possible to manually place the files on the disk (and if so, which files?)

        Comment


        • #5


          I'm guessing that Workshop thinks you've already copied the cards to the uSD and so you don't need to do it again.

          Try pressing Shift-F9 to force a rebuild.

          The files are generally the .GCI and .dat files in your project folder. There may be a .txf (IIRC) if you are using a strings object.
          Mark

          Comment

          Working...
          X