Announcement

Collapse
No announcement yet.

controlling oled via terminal

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • controlling oled via terminal

    is there a problem to manage the oled via a terminal?
    when I send an hex 42 ff 00 to change the background color but
    there change noting the oled response not at all on all the command I send

    Only the reset button on the terminal works.



    what also not work anymore is my Bascom-avr code to controlled the oled
    look at my test code
    can anybody help my way it not work any more



    is it possible that the firmware PmmC 2.7 the cause is of my problem?



    $regfile = "m2561def.dat"

    $crystal = 14745600

    $hwstack = 96

    $swstack = 28

    $framesize = 96

    $baud = 115200

    Print "1"

    Dim Z As Byte

    Print Chr(&H55) 'autobaud

    Gosub Warte

    Print Chr(&H45) 'clear screen

    Gosub Warte
    Print Chr(&H42) ; Chr(&Hff) ; Chr(&Hff) 'set background ( here in white )
    Gosub Warte

    Print Chr(&H73) ; Chr(&H02) ; Chr(&H01) ; Chr(&H02) ; Chr(&H00) ; Chr(&H00) ; "HELLO WORLD" ; Chr(&H00)

    Gosub Warte

    Wait 30

    Print Chr(&H59) ; Chr(&H03) ; Chr(&H00) 'power down

    Warte:

    Do

    Print Z

    Z = Inkey()

    Loop Until Z > 0



    Return

  • #2


    is it possible that the firmware PmmC 2.7 the cause is of my problem?
    Is that a typo? The highest SGC PmmC for Goldelox is 1.7.

    When did this stop working?

    What happens if you use FAT Controller, can you paste a log from there?

    Which display are you using and what shows on the 'splash' screen?

    We haven't shipped modules with SGC for a while now, if it is a recent module it has almost certainly been shipped with SPE, which uses a completely different protocol.
    Mark

    Comment


    • #3


      oke it's an uOLED-160-G1 the serial one.
      yes typo must by 1.7.
      can it by that there must be a pullup restister to the 5volt?

      I measured that my code indeed send the commands to the uOLED but it
      doesn't response
      I think that the output signal of my ATmel is to low to trigger the OLED!!

      I'm going to measure the signal with a scoop and come back with the results.

      Comment


      • #4


        can it by that there must be a pullup restister to the 5volt?
        There's a 10k pullup to 3.3v on the OLED's RX line, to stop 'noise' if the pin is not connected.

        The Goldelox chip is only 3.3v so there should be adequate signal to drive it and it is 5v tolerant

        Have you got TX and RX connected the wrong way around?
        Mark

        Comment


        • #5


          I have tried it to change the tx rx but no results

          I have the programming cable and the workshop4 IDE that works fine.

          my ATMEGA2561 have an cpu clock speed of 14,745600MHz is it posoble that it to fast is for the uOLED?

          Comment


          • #6


            The clock speed should have no relevance to it.

            Check that the display is working using FAT Controller.

            Then have a look at what the ATMEGA is sending using a Scope, if you are still having trouble post the scope information here.

            You should be checking for ACKs after you send commands, maybe you are sending the autobaud too quickly after the display powers up. You also may need to send more than one Autobaud.
            Mark

            Comment


            • #7


              what do you mean with "Check that the display is working using FAT Controller"?

              Comment


              • #8


                FAT Controller is the tool to send and receive SGC commands from a PC http://old.4dsystems.com.au/prod.php?id=70
                Mark

                Comment


                • #9


                  Hello again.
                  I have used the FAT controller and there is a problem...
                  when I connect my uOLED end open the port is send a couple of times the auto baud.
                  then coms the FAT with an error autobaud failed.
                  I use Windows 8 64bits can this by a problem?

                  Comment


                  • #10


                    oke there is a big problem I have tried it on Windows xp but the same problem

                    question can I flash the oLED to an older version of the PmmC?

                    Comment


                    • #11


                      Windows 8 should be the same as XP (as you have found).

                      You can always go back to an older PmmC, although that version is very stable.

                      Actually I don't think you will be able to go back to an older version as it is looking like there is something wrong with the display.

                      What is showing on the splash screen?
                      Mark

                      Comment


                      • #12


                        I have an older PmmC 1.6 loaded in the oLED and now it's working again but not so stable
                        as a while ago. aim going to try an other PmmC looking if that works better

                        Comment


                        • #13


                          The only difference between R1.6 and R1.7 is

                          Fixed 64mb issues with (re)initing and reuse after byte read mode
                          Added support for uLCD-144 (extra Nop in byte read routine)

                          It's unlikely the first applies to you and the second certainly doesn't.

                          Could you perhaps have the run jumper installed?

                          That way it could possibly appear to not respond on Reset if a uSD was inserted and appear normal if there was no uSD inserted?
                          Mark

                          Comment


                          • #14


                            Is it posible that an downloaded PmmC file is corrupt an the PmmC loader checked not is it is good or wrong?

                            Comment


                            • #15


                              You can redownload the PmmC from here http://old.4dsystems.com.au/prod.php?id=201

                              If the FLASH on the Display is worn out (never really seen that happen before) then the PmmC could download incorrectly.

                              Have you checked to make sure the run jumper is not installed?

                              How are you powering the display?
                              Mark

                              Comment

                              Working...
                              X