No announcement yet.

4D programming cable unstable

  • Filter
  • Time
  • Show
Clear All
new posts

  • 4D programming cable unstable

    I just bought a 43PCT and a programming cable from
    Connecting just the cable I can get it to work most of the time and it shows up in device manager as com20. I do get a reply using the terminal utility using a jumper between TX/RX.
    A couple of times I got the cable working with the display but it is unstable. Most of the time I get "Device not responding". I have tried two computers (win7 32-bit) and two displays (I have an older 43P also) The driver is date:19.03.2014. I have also tried the extra settings program changing power settings from 32 to FA.
    After hours struggling with this i connected a cheap $2USD FTDI board and it works every time.
    What do you suggest?

    Best Regards
    Armand Aanekre


  • #2
    On the surface of it it would appear that the programming cable is faulty and that you need to contact mouser to organise an RMA.

    What is the effect on the display when you get the 'Device not responding' messages?

    Is the cable connected directly or through a hub?

    It is surprising that a 'cheap $2 FTDI board' will work 'as supplied'. Did you add extra circuitry to supply the required reset signal? Was it already there?



    • #3
      The display is working fine when I get the 'Device not responding' messages.
      On both tested computers I used the cable without a hub.
      When checking the cheap FTDI board I was referring to is in fact $7 , but it has a DTR line I use for reset.
      Is RMA the next step or is there anything else I should try?