Announcement

Collapse
No announcement yet.

Trying to run pi calculator demo, but not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trying to run pi calculator demo, but not working

    Hello,
    I have a uLCD-32PTU, I was trying to run the calculator demo.
    I downloaded and installed visi genie Raspberry Pi Library on the Pi,
    installed the wiringPi, and downloaded the demo zip.

    Then I opened the calculator 4Dgenie file with workshop and try to build it to SD card. This gives me the warning of device is 32PTU but code is for 32PT, I selected continue and download this to the SD card.

    After this I put SD back to LCD and powered LCD with Pi and the screen is same as in the Youtube video demo (with no response to touch) when .c file is not running.
    Then I start the .c file, and calculator demo is running.
    But now the number on the top of LCD didnt go to 0 and still no response to touch. Also on the Pi side, the demo program gives a 0 when the LCD keyboard is touched and no further response.

    Could you help me to find what is the cause of the demo not working?
    Is it because I missing something in download and install step? 32PTU and 32PT code are not compatible? or Do I need to change anything in the .c code?


    Li

  • #2
    Hello Li,

    The demo was written for the uLCD-32PT, so you need to change the target device.
    In the Project Tab, change the display to be the uLCD-32PTU. Build and download to your 32PTU.

    That should help.

    Regards
    James

    Comment


    • #3
      Hello, thanks for the fast response.
      I tried change the display to 32PTU and rebuild, but the result is the same.
      What else should I check?

      Comment


      • #4
        Hello Li,

        Did you follow all the instructions that are listed on the GitHub page, including disabling linux from using the Serial Port for normal Linux stuff, so that the demo application can use it instead to talk to the display module?

        Regards
        James

        Comment


        • #5
          I didn't disable that yet, my cmdline.txt does not have exact same line as kgdboc=ttyAMA0,115200 console=tty1 , what should I do?
          for the initab file I edited as the instruction said.
          Last edited by sc13ece; 16 January 2015, 09:32 AM.

          Comment


          • #6
            What does your cmdline.txt file have it in?
            What distribution and version are you using?
            James

            Comment


            • #7
              Hello,
              My cmdline.txt:
              dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p6 rootfstype=ext4 elevator=deadline rootwait

              My distribution is:

              PRETTY_NAME="Raspbian GNU/Linux 7 (wheezy)"
              NAME="Raspbian GNU/Linux"
              VERSION_ID="7"
              VERSION="7 (wheezy)"
              ID=raspbian
              ID_LIKE=debian
              ANSI_COLOR="1;31"



              Comment


              • #8
                Hi,
                Delete the part that in red bold line.

                dwc_otg.lpm_enable=
                0console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p6 rootfstype=ext4 elevator=deadline rootwait

                And also don't forget to comment out this line from etc/inittab by putting # on it.


                T0:23:respawn:/sbin/getty -L ttyAMA0 115200 vt100

                Also check the baudrate use by your 32PTU display and the baudrate used in your .c codes. Those baudrates should be the same, or else will not work.

                Regards

                Comment


                • #9
                  Hello,

                  Demos are working after following Abed's instruction.

                  Thanks to James and Abed.

                  Comment

                  Working...
                  X