Announcement

Collapse
No announcement yet.

Display connected to TTL to RS232 adapter, only TX works

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Display connected to TTL to RS232 adapter, only TX works

    I have a OLED-96-G2 that I wanted to communicate via RS232 serial. To do that I am using this converter:
    https://www.sparkfun.com/products/449
    However, for some reason when all is hooked up I can only send commands to the screen but I never receive an ACK back.Realterm tells me that it is getting a BREAK signal. Is there perhaps a configuration that I need to set to get this to work?
    I did make sure that the RX wire is hooked up probably. I even get a little flash from the RX led on the converter board. What is weird is that the RX led is perpetually on. It just flashes more brightly after I send a command.

    This is 9600 baud all default factory setting.

    thanks
    Last edited by tianshiz; 14th February 2015, 06:34 AM.

  • #2
    How do you know you are sending commands to the screen? (eg are they being actioned by the display)

    I wonder if you have RX and TX back to front,as I imagine that could the symptoms you describe with the RX LED.

    Can you provide a photo showing the way everything is connected?
    Mark

    Comment


    • #3
      When I use putchar, I can actually put a char on the screen. But no ACK is received

      I just tried to short TX to RX and I was able to get the proper echo, so at least the rest of my setup seems to be working.

      ​Here is a pic of my setup. What do you mean by RX and TX back to front? You mean reversed?
      Attached Files

      Comment


      • #4
        Yeah, reversed, but since you can put a char on the screen that can't be the case.

        The levels of the display are actually 3.3v, and normally that shouldn't cause an issue, but I'm not familiar with the 'converter' chip in use and there is no part number specified for it,

        Can you try and power the converter with 3.3v and see what happens?
        Mark

        Comment


        • #5
          that was it! Putting it at 3.3 solved the issue. Strange though

          Comment


          • #6
            Yes, the converter should work at 5v, but it obviously is a bit 'odd'.

            Hopefully you can use pin10 from the display for the 3.3v
            Mark

            Comment


            • #7
              hi again.

              I'm having some separate but perhaps related issue. When I boot up the display I get the message "missing interrupt". This can only be remedied with a reset or power cycle of the screen, not the device I'm hooked up to. I suspect that the device I'm hooking on to might be doing something on startup to the device. However I'm not sure what that is and how it could cause this error. Any idea what could lead to the "missing interrupt" issue I'm having?

              Comment


              • #8
                Just where is this message coming from? What environment are you using? Where did your code come from?

                I'm not aware of any such message being produced by the system on its own
                Mark

                Comment


                • #9
                  this message pops up on the display. I have the display hooked to a serial I/O on a National Instruments PXI. Basically this display is in serial mode and the PXI outputs text on it.

                  Comment


                  • #10
                    There is no "missing interrupt" message that can be produced by the uOLD-96-G2.

                    Perhaps you are seeing "missing interr" on the display?

                    This is actually the truncated first part of "Missing internal function xx" and should not occur.

                    It occurs in the current SPE version when 0x0000 is sent as a command. This command code is not valid, so you shouldn't really ever see this message.

                    The next SPE version will NAK this command if it is sent.
                    Mark

                    Comment


                    • #11
                      Hi mark
                      i assume spe is the firmware? Any idea when the next one will be out?
                      Thanks

                      Comment


                      • #12
                        Should be out in the next week or two, but I'll put the SPE change here, so you can use it now.

                        Unzip the attachment to C:\Users\Public\Documents\4D Labs\4DUpdates\Utils and reload SPE using 'SPE Load' from the tools menu
                        Attached Files
                        Mark

                        Comment


                        • #13
                          thanks so much! That fixed the problem!

                          Comment

                          Working...
                          X