Announcement

Collapse
No announcement yet.

In case of use c code

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • In case of use c code


    I'm using uCAM-II with Texas Industries' TMS320F28335 and Code Composer Studio V6.

    I have to use uCAM-II through only my own C code.
    but now, I have some problem.


    (Reference uCAM-II datasheet's page16, JPEG Pictures (Video))
    At present, I'm successfully give commands to camera that 'SYNC', 'Initial', 'Set Package Size' and each 'ACKs'

    The biggest problem that I have is the camera usually dead(don't response to me) after I turned on the camera and during give a some command to the camera.
    Almost, the camera didn't SYNC although turned on.

    In my opinion, when the camera into a sleep mode, and then it doesn't wake.
    Because when i turned off the main power and turned again (at dead situation), it works well. But it doesn't mean everytime this way works.

    I'm use loop code for give a command several times at once, because I doubt the camera don't take a commands.

    I Also use your demo program of uCAM-II.
    Even if the camera into a sleep mode, it was wake and operate well when I give a some command.

    I don't know what is the problem and take a measure(how to resolve this).
    I want your response or questions for resolve this problem.


    I'll wait your reply.

    Thank you.

  • #2
    The uCAM-II has rather specific power supply rise time requirements (as per the datasheet). If they are not met the camera can appear to be dead.

    I have one particular linear power supply that rise in such a way the that uCAM-II never works with it.

    In general the solution is to use a FET to switch on and off the uCAM under the control of your processor. Not only does that help the uCAM to work every time, it also gives you a way of performing a hardware reset on it.
    Mark

    Comment

    Working...
    X