Announcement

Collapse
No announcement yet.

Keybord bugged ?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Keybord bugged ?

    Hello

    I've some problems with a custom Kb (in fact it's the same with originals keyboard)

    1 - only some keys works (it's pasted code )
    2 - very strange things when I disable all touch capacities before showing keyboard and enabliing touch for the keyboard : when touching a key , actual screen/form is cleared and the 1st form is partially displayed (backgrounf image) and there is no code to display the first form in keybord subroutine. It's like the LCD was rebooting (program is in RAM)



    Workshop 4.1.028 (I've desinstalled and reinstalled WK 4 : same things)
    µLCD43PT

    I join my project
    Touch "Mesure" button, touch "O" button
    Try with the 3rd line of keyboard function uncommeted ( img_ClearAttributes(hndl, ALL, I_TOUCH_DISABLE); ) and touch a key ... Attached files Tour.zip (128.5 KB)

  • #2


    Remove the

    #inherit "KbButtonsConst.inc"

    Which comes from the program you copied from

    and then fix up the compile errors (mostly referring to ikeyboardxxx rather than iKeyboardxxx)

    Your ikeyboardxxxs are referring to constants inherited that are from the wrong program.
    Mark

    Comment


    • #3


      Thank you for this quick reply

      That's work. Silly I am to not see it (and not changing the name of the keyboard )

      It's the problem to work with code sample instead of language reference : this make me lazy .


      Thanks again

      Comment

      Working...
      X