Announcement

Collapse
No announcement yet.

43P going black

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 43P going black

    Hi,
    we have project with uLCD-43P display that is showing messages sent over COM0, instaled inside motor turnstile. We installed over 10 of these displays with same program and few of them starts going black. It looks that blacklight is off, but program still works because it replies to messages on COM0. When we do SystemReset() it starts working again normally.

    Do you have any suggestions about this effect?

  • #2
    Gee, it sounds like you have 'just' set contrast to 0, which will turn off the backlight, but surely if you did that you would know it.
    Mark

    Comment


    • #3
      We also tried to modify program by adding code below called every minute:
      Code:
       gfx_Contrast(15);
                  pin_Set(1, BACKLITE);
      After that modification we have white screen with green lines instead of black screen, but result is same - program works, but not showing messages on display.

      Comment


      • #4
        Hmm, I just meant to set the contrast to 15.

        Nevertheless that extra line is exceeding instructional

        Can you remove your modifications and add this line near the start of your code

        Code:
                pin_HI(BACKLITE);
        Let me know if it fixes the problem
        Mark

        Comment


        • #5
          Our problem is not in changing backlite state by program, it was just for test.
          Problem is that display (I mean LCD part) spontaneously change backlite state and stops responding to program instructions, but program itself is still running.

          Comment


          • #6
            Yes, I understand, please try what I asked above
            Mark

            Comment


            • #7
              Has that fixed it?
              Mark

              Comment

              Working...
              X