Announcement

Collapse
No announcement yet.

"error 8" on display after programming with scriptc.exe?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • CPoirier22
    replied
    Hi Mark,

    Kind of a "oh-duh" moment. Thanks for catching! Also appreciate the quick response.

    Thanks!
    Carl

    Leave a comment:


  • ESPsupport
    replied
    The script is set up to load the program to RAM, if you have Workshop set that way you get the same error.

    Specifying Flash works from both workshop and the script.

    Since the program is too big to run from RAM this is what is probably causing the 'Error 8'.

    Leave a comment:


  • CPoirier22
    replied
    Hi Mark,

    The .zip file is on its way. I'm using the 4D Programming Cable on a Win7 box. When I use Workshop4 it programs perfectly. When I use the batch fileI emailed, I get the error 8.

    Thanks for any help,
    Carl

    Leave a comment:


  • ESPsupport
    replied
    From appendix B of the internal functions reference Error 8 is "Failed to load program from FLASH". I've never seen this before.

    Can you give me some more information about your platform, hardware and programming method (programming cable, distances involved, etc.)

    Can you also use zip project and send it to mark at 4dsystems dot com dot au along with your script.

    Leave a comment:


  • "error 8" on display after programming with scriptc.exe?

    Hi,

    I thought I previously had the command line programming working (by having scriptc.exe, load4dglprogram.4dscript, file.4xe, & file.cfg files all in one directory). But I recently it seems to not be working. After the script runs, it says it was successful, but the display has "error 8" in the corner and I can confirm it was not programmed. If I program from Workshop, it programs fine.

    Any tips on what to look at next?

    Thanks,
    Carl
Working...
X