Announcement

Collapse
No announcement yet.

7" uLCS-70DT with external power source not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 7" uLCS-70DT with external power source not working

    Hi,

    I'm testing my screen with the GenieArduino_demo.

    When I power my uLCD-70DT over the programming cable with the USB port of my laptop, everything works fine (see pic1).

    However, when I connect the screen to an external power supply (Velleman power supply model PSSE10, 5V 1A), the screen updates once but then stops responding to the TX signals of the arduino. But touch is still functional. (see pic2)

    Edit: sometimes it updates veeery laggy, once every 5-10 seconds.

    I need to power the screen over the external power supply because there wont be USB port in the box where the screen comes in.

    The external power supply is connected to Jack 1 on the screen.

    Thanks,

    Kind regards,
    Bert

    pic1:
    Click image for larger version

Name:	20150615_143545_resized.jpg
Views:	30
Size:	997.9 KB
ID:	45796

    pic2:
    Click image for larger version

Name:	20150615_143625_resized.jpg
Views:	34
Size:	1.17 MB
ID:	45797
    Last edited by Bertf; 15 June 2015, 11:23 PM.
    www.forestplus.be

  • #2
    I can't see any ground connection between the Arduino and the display, you will need that
    Mark

    Comment


    • #3
      Perfect, thank you! This did the trick. It's working now

      Click image for larger version

Name:	20150616_081217_resized.jpg
Views:	35
Size:	916.9 KB
ID:	45822
      Attached Files
      www.forestplus.be

      Comment

      Working...
      X