Announcement

Collapse
No announcement yet.

70DT Visi genie magic event

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 70DT Visi genie magic event

    Hi,
    I am currently using the 70DT in Visi Genie and have been using the UpDownRepeat example code to inc/dec my LED digits. I sucsesfully compiled the first 5 sets of buttons but when I went to upload the 6th set it will now not load. I get the error message "Function cant be nested
    Is there a limit to the number of magic events you can use? and if so how do I delete the events?
    Thanks,
    Lewis

  • #2
    Sounds like you have put a function inside a function like the message says.

    Check the Genie code you have added. (between your 5th and 6th load)

    This will not have anything to do with the number of events.
    Mark

    Comment


    • #3
      Hi Mark,

      Thanks for the quick reply.

      The code I have added is a copy of all the previous codes, the only thin I can think of is the numbering of the MagicEvents, please see link for image<a href="http://s173.photobucket.com/user/Lewis_Gaskin/media/IMG_0837_zpsvzp7u9h5.jpg.html" target="_blank"><img src="http://i173.photobucket.com/albums/w50/Lewis_Gaskin/IMG_0837_zpsvzp7u9h5.jpg" border="0" alt=" photo IMG_0837_zpsvzp7u9h5.jpg"/></a>MagicEvent10 sits under MagicEvent1 and then MagicEvent11?
      could this cause the error code?

      Comment


      • #4
        Hi Mark,

        Thanks for the quick reply.

        The code I have added is a copy of all the previous codes, the only thin I can think of is the numbering of the MagicEvents, please see link for image <a href="http://s173.photobucket.com/user/Lewis_Gaskin/media/IMG_0837_zpsvzp7u9h5.jpg.html" target="_blank"><img src="http://i173.photobucket.com/albums/w50/Lewis_Gaskin/IMG_0837_zpsvzp7u9h5.jpg" border="0" alt=" photo IMG_0837_zpsvzp7u9h5.jpg"/></a> MagicEvent10 sits under MagicEvent1 and then MagicEvent11?
        could this cause the error code?


        sorry needed some spaces in there

        Comment


        • #5
          Hmm, can't spot anything wrong there.

          Can you use file, zip project and attach it here, or email it to mark at 4dsystems dot com dot au?
          Mark

          Comment


          • #6
            Hi Mark,
            Thanks for that, was looking at the screen for too long yesterday.

            Comment

            Working...
            X