Announcement

Collapse
No announcement yet.

After installing kernel for 4DPi-24-HAT, Raspberry Pi won't boot

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • After installing kernel for 4DPi-24-HAT, Raspberry Pi won't boot

    I'm a NOOBS and thought it would be fantastic to get a small touchscreen integrated into the RPi. I purchased the 4DPi-24-HAT display and followed the instructions included with the display and can also be found here:

    http://www.element14.com/community/s...rt%20Guide.pdf

    After attaching the display and then rebooting, nothing appears on my 4dPi-24 display.

    So I reconnected my HDMI cable and the cosole show my RPi stops on boot at the following message:

    [ 1.656008] 4d-hats spi0.0: 4d-hat registered, product code = ad

    If I then remove the 4Dpi-24 display and repower, the RPi then stops on:

    [ 2.688221] usb 1-1: new high speed USB device number 2 usering dwc-otg

    I have re-installed Raspbian twice and followed the quick start instructions to double check I wasn't making any mistakes. Can anyone shed any light on what i wrong and how to resolve it?

  • #2
    Hi Lukef

    Welcome to the forum

    When you were following the instructions and you did the wget to get the tar file off the 4D Server, then you extracted the tar, did you get an errors coming up?
    Were you doing this as root?
    When you downloaded the file using wget, did you happen to download it on to the /boot/ partition, or did you download it somewhere in your /home/ for example?

    I have noticed before that if I downloaded it (or copied via my PC) to /boot/ which is the FAT partition, there would not be enough space to extract the tar and it would error at the very start.

    Are you running all the commands direct off the Pi with a keyboard, or did you SSH into the Pi to do this?

    Regards
    James

    Comment


    • #3
      Thanks for the quick reply James.

      I'm not sure about the download - I believe it was the boot partition, but will double check.

      I used the terminal application directly on the Pi using a keyboard. I had root access and completed the #sudo su command to gain super user access. I didn't see an error at the very start, but it extracts very quickly and therefore there could have been an error I didn't pick up.

      I'll run it again from scratch and see if I missed any errors. I'll update you then!

      Comment


      • #4
        Ok no problem. Before you do the wget, put yourself in the /home/pi folder or something, or make a downloads folder in there, and try again.
        Hopefully that resolves it.
        James

        Comment


        • #5
          I just tried again from scratch, with the same result.

          I created the directory /home/pi/download and used wget to download the image.

          I then ran tar and applied the image:

          Click image for larger version

Name:	Screenshot 2015-08-12 15.54.51.png
Views:	269
Size:	24.8 KB
ID:	47070


          Everything seemed to work correctly and I didn't see any errors:

          Click image for larger version

Name:	Screenshot 2015-08-12 15.55.36.png
Views:	250
Size:	39.8 KB
ID:	47071


          I then updated /etc/rc.local:

          Click image for larger version

Name:	Screenshot 2015-08-12 15.59.43.png
Views:	230
Size:	34.7 KB
ID:	47073

          Just an FYI, I also took a screenshot of what was in the /etc directory as there was no fb1 file (I'm not sure if there is even supposed to be):

          Click image for larger version

Name:	Screenshot 2015-08-12 15.59.03.png
Views:	214
Size:	103.6 KB
ID:	47072

          I then turned off the Pi and attached the 4DPi-24 display and turned it back on. Nothing came up on the 4DPi-24. I then attached a HDMI cable and saw that the same error as before was displayed (slightly different number):

          [ 1.655975] 4d-hats spi0.0: 4d-hat registered, product code = ad

          Anyone have any more ideas?

          Thanks, Luke

          Comment


          • #6
            Are you running this on a Pi1 or a Pi2 ?

            You are running Raspbian, or are you running NOOBS?
            James

            Comment


            • cluderay
              cluderay commented
              Editing a comment
              FIXED. Read on...

              I had exactly the same problem as Luke when using Raspbian installed via NOOBS. Last line during boot hang was the same ([ 1.662317] 4d-hats spi0.0: 4d-hat registered, product code = ad).

              Two problems.

              #1 The LCD backlight was off. Moving the jumper on the reverse side to the right now made the output visible.

              #2 The boot process still hung because the boot partition wasn't found.

              This was fixed by booting on another SD card with unmodified Rasbian installation, and connecting the SD card with hanging modified kernel using a USB card reader. Using "cat /proc/partitions" showed the boot partition on the modified kernel SD was now number 6 (shown as "sdc6" in attached command line pix). Then after shutdown the modifed kernel SD was placed back into the Pi2 board and the boot sequence monitored on HDMI. During the boot "SHIFT" was held when prompted to break to NOOBS setup. Select the second option "Edit config". Then select the second tab "cmdline.txt". Change the "root=/dev/mmcblk0pX" to "root=/dev/mmcblk0p6"....where the last digit "6" in my case could be different in yours....use whatever you found using the SD card reader for your particular installation. Click OK and then click EXIT to quit the NOOBS configuration. The boot should now work and startx desktop should appear on the LCD screen.

              I'll post an image of the partition information in my case. The upper 7 are from the unmodifed Rasbian SD partitions on the Pi2 board. The bottom 6 are the Rasbian SD partitions with 4dsystems kernel applied, connected to Pi2 via USB card reader. From this you can see the boot partition should be "6".

              Maybe there's a better way to do this, but as I'm new to the Pi I'll let the experts clarify!
              Last edited by cluderay; 13 August 2015, 01:06 AM.

          • #7
            Finding the root resides on partition #6 (sdc6):
            Click image for larger version

Name:	20150812_161029.jpg
Views:	193
Size:	2.88 MB
ID:	47088

            NOOBS setup showing cmdline.txt with 4dsystems kernel applied. Root path now edited to show partition #6 (mmcblk0p6):
            Click image for larger version

Name:	20150812_164322.jpg
Views:	234
Size:	4.47 MB
ID:	47087
            Attached Files

            Comment


            • #8
              This shouldnt be this difficult - Ill get someone to have a look at this ASAP.

              Can you please try standard Raspbian, and not NOOBS - you shouldnt have any problem with that.

              Regards
              James

              Comment


              • #9
                Thanks for looking into this James. Please bear in mind however that many newer users will likely be using Raspbian installed via NOOBS. It would be great to have a 4DPi 24 HAT solution that's flexible enough to accommodate Raspbian irrespective of how it was installed (or else as you suggest, simple instructions to achieve the same).

                Comment


                • #10
                  Hi again

                  OK we have managed to fix this for NOOBS now.

                  The same download has been replaced. It should be compatible for both Raspbian and NOOBS now.

                  If you want to 'fix' the old version (Not relevant if you are just downloading it again now), you can edit the cmdline.txt file and made a small modification:

                  root=/dev/mmcblk0p2 has to be changed to root=/dev/mmcblk0p6 if running on NOOBS

                  Note this is only relevant if you have downloaded prior to now. If you download now, it will just work - please give it a test out.

                  Many thanks

                  Regards
                  James

                  Comment


                  • #11
                    I'll give it a whirl on Monday (my display module is in the office and I'm at home....) and tell you how I go. Thanks for your all your help so far, amazing responsiveness and support!

                    Comment


                    • #12
                      Hi all,
                      I too experienced replication of Luke & cluderay's results.
                      I started with NOOBS from cards that came with two version 2 Raspberry boards from Element14.
                      I think the NOOBS was dated 18/02/2015 - too old?
                      In /dev (not /etc as mentioned above) I also had no fb1.

                      I checked the cmdline.txt file and ......0p6 was set up correctly.
                      I changed the backlight jumper as suggested.

                      But still absolutely no display or even hint of it.

                      So, I downloaded the latest Raspbian image and started again.
                      This time all was well and the display worked.
                      Checked /dev again and this time fb1 was present.

                      In my case now, as soon as the Raspberry starts to boot up the display flashes very briefly.
                      Then probably about 2/3 in to booting up the text starts to appear and then the GUI appears.

                      So, it appears there is still something different between the Raspbian image and NOOBS.
                      But Raspbian is the way to go with this add-on.
                      Regards,
                      Laurie

                      Comment


                      • #13
                        Hi, 18/02/2015 firmware does not support HATs on RPi2 - reading device tree overlays from EEPROM does not work (should be OK on RPi1). Console now appears a few seconds later on both NOOBS and Raspbian.

                        To enable early console

                        fbcon=map:10

                        should be added to /boot/cmdline.txt file.
                        Last edited by strancara; 21 August 2015, 06:03 PM.

                        Comment

                        Working...
                        X