Announcement

Collapse
No announcement yet.

Workshop 4 not able to copy to SD Card

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Workshop 4 not able to copy to SD Card

    Hi,
    I have worked through some of your examples and been able to load all the files need onto the Micro SD card.
    However I have started on my project and are not able to get the needed files transferred / copied to my SD card.
    Each time the copy windows freezes, goes non responsive then the entire drive fails.
    I am running a Windows 64 PC with admin rights I have tried 2 x 4 gig SD cards that came with 2 separate displays from you guys.
    I have the display uLCD-28ptu connected via the 4D cable and is showing as connected on COM 4.
    The SD card is connected via a USB adapter which has work fine for the first few examples and is brand new.
    I have updated the PnmC and formatted both cards using the RMPet program and you how-to create 50-50 FAT and RAW
    I even believe I have fd one of the cards as windows will not recognise it at all now...
    Please any help as I am now dead in the water.....

  • #2
    You seem to be describing a Windows hardware issue, but then again maybe not.

    Do you have a URL that points to your USB-uSD adapter?
    Can you access the cards 'normally' via Windows?
    What brand are these cards?
    If you remove all USB devices from you computer except the uSD adapter, does it work?
    At one point there was a bug in Windows that meant if you tried to access a uSD on an adapter 'too quickly' after it was inserted all access to the uSD would lock up. Can you remove the adapter, wait a few seconds and then reinsert it, wait a few seconds after Windows appears to 'add it' and then see if it works?
    Mark

    Comment


    • #3
      I can access the card through My Computer no worries.
      Unfortunately I cant find the URL of the reader I am using, I will keep searching for a windows fix maybe

      I have just noticed that once I open the RMpet program I have the below message in the right column

      RMPET.rtf not found, no help available.

      Comment


      • #4
        How are you running rmpet?

        The RTF isn't all that important, it is in the C:\Program Files (x86)\4D Labs\4D Workshop 4 IDE folder and when I run rmpet from within workshop or from the start menu it is found.
        Mark

        Comment


        • #5
          I was able to complete a compile however I used the 'uSD' destination not the 'Run Flash' destination under Project.
          This process was able to transfer 2 files to the SD Card a .dat and .4xe file.

          It appears to have trouble with the larger .gci file, it only 111 mb

          Comment


          • #6
            Trouble, in what way?

            You still haven't said what brand od uSD card you are using
            Mark

            Comment


            • #7
              Scrap that I am sorry after the 2nd card and 2nd card reader and the 2nd card extension it got my program to transfer with 0 errors
              Its sooo frustrating what works one minute ago now is rubbish... that the IT industry for you
              again sorry to waste your time

              Comment

              Working...
              X