No announcement yet.

Playing with FRAMEBUFFER and 4DPi 24 HAT

  • Filter
  • Time
  • Show
Clear All
new posts

  • Playing with FRAMEBUFFER and 4DPi 24 HAT

    Hello again,

    My 4 DP i 24 HAT works fine.

    So now I can fine tune the RASPBIAN GUI to 640 480 pixels in order to see the windows completly when I launch a program in the GUI.
    Using SSH through my PC I can remote on the PI the command
    FRAMMEBUFFER/devs/fb1 startx -- -dpi55
    and the PI GUI screen size is changing accordingly on the 4DPi 24.

    But I want to have this change at boot set-up so that every time I start the PI it has a 640 X 480 screen size on the 4DP i 24.
    i have used the editor nano /etc/rc.local to enter this screen set up in the etc/rc.local file adding a new line before the line exit(0)
    sudo FRAMEBUFFER=/dev/fb1 startx -- -dpi55

    The result: even if the screen size has changed after boot sequence, now I retrieve an old issue:
    I have an error message "No session for PID xxx"
    and my USB DISK is not mounted!

    So my question is:
    How to set up PI GUI 4DPi 24 HAT screen size so the PI keeps it every time i start it ?


  • #2
    In fact I'd be interested to know how you can do that (Full GUI on the 4DPi24) ?? Hummm ?
    Click image for larger version

Name:	FullGUI on4DPi25HAT.png
Views:	117
Size:	129.5 KB
ID:	48930


    • #3
      Hello Jean

      Someone will be investigating your first post today.

      Regarding your 2nd post. You have 320x240 pixels on the 4DPi-24-HAT. Display a full GUI to me doesn't make any sense, you just do not have the pixels for it.
      If the 4DPi was higher resolution, then sure, but you have limited pixels. its not like your PC monitor which maybe HD 1920x1080 or whatever, which can display the full GUI easily.
      Even if you were able to scale things by changing the DPI etc, its going to look rather odd as its would be trying to display everything with limited pixels, and you likely wont be able to read any of the text as it would be all fuzzy.



      • #4
        Hello Jean

        dpi is set the standard way, like:
        which means:

        login as pi
        nano .Xresources
        add this line:
        Xft.dpi: 75

        the startx line in /etc/rc.local can be commented out, you can just select boot into GUI in raspi-config



        • #5
          Thanks a lot! All is ok now! The Raspbian GUI can be used directly on the 4DPi 24 HAT!



          • #6
            So, I am new and I see this is from 2015 but I have a similar question. What settings is 4D Systems using for the resolution settings? I would like to match the pictures on their website.
            My install is fine but when all icons and dialog boxes are huge! Nice product! I think I search the forums and this is the closest to my question.
            I followed all instructions and install went nicely on a Pi2, loaded from NOOBS 1.9, apt-get update, upgrade, used v10 for 4DPi-24 etc.


            • #7
              The resolution is always 320x240.

              I'm not sure which pictures you are referring to. Many of the pictures on the site are 'generated' (as taking photos of everything can be almost impossible to get the angles/lighting, etc. right), so often these pictures will be different to 'real life'.


              • #8
                Ok, true, I know that the screen is 320x240.
                I understand marketing tricks to make things look good. But, I do have some expectation that what I see on your website and what I will see might be similar and I hope that 4dstaff will be helpful.
                Difficult to describe.
                What I see on my 4DPI-24 GUI icons, dialog boxes etc seem to be scaled for what I see on the HDMI (1900xwhatever it is for my monitor).
                If you look at post #2 in this thread and the 4DPI-24 product page, I would hope my screen might be similar.
                Please help me



                • #9
                  Hmm, I've not familiar with this particular product and the person who is is away for Easter, so it will take a few days for him to respond to you.


                  • #10
                    Hello yl-sc

                    As Mark said, the resolution of the 4DPi-24-HAT is 320x240.
                    So you are physically limited to this number of pixels. However, there are ways to scale the screen to fit more on it, however you may sacrifice quality/sharpness.

                    You can change the DPI of the Pi's output. You can find the instructions for this in Section 4.9 of our Datasheet, available from the Product Page on our website.
                    You can also shrink and change the scale of the menus and icons, however this may only be possible to do from the GUI itself. From memory its in the preferences or options, in the File Explorer. The window will likely be too large to view, however if you have a keyboard connected and a mouse, you can hold ALT and move the window around to get to it all

                    Then there are more elaborate things you can do, such as scaling with a framebuffer.
                    Never used it and was passed that link from someone else. So unsure how to use it exactly.

                    I hope this is of some help



                    • #11
                      James and Mark,
                      Thank for the quick and timely replies; I appreciate it.
                      But, it does not address my problem. Actually after some more research, my issue is not related to your device. It seems it is the OS desktop is not doing what I might expect. My PC monitor supports many display resolutions (I guess my earlier post was incorrect wording). Your device is 320x240 only. On my Windows based PC, I can adjust the resolutions etc and Windows will adjust all icons, dialog boxes etc. When I use your device, Debian or LXDE is not scaling what-you-see to the display resolution. When I route the output to my HDMI monitor (same as used for the Windows PC), LXDE only reports one resolution. Oh well, I think that I am done in this forum.
                      Thanks again.