Announcement

Collapse
No announcement yet.

uLCD-320 PMD2 - firmware upload & slideshow problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uLCD-320 PMD2 - firmware upload & slideshow problems

    Greetings!

    1. I am having a problem uploading the v9 firmware. When I attempt, the pmmc loader indicates that it is "waiting for the device" indefinitely. I have left it alone for some time but still no luck

    2. My slideshows will not run. I have set up a slideshow to rotate images with a 5000ms delay in between each.. They seem to load properly to the device, and when the load is completed the LCD freezes on the first image. The same happens if I short the jumper and run it on power only. I have tried jpgs and bmps, 16 bit, 8bit, etc. all set to the proper size (240x320) but still no success.

    any thoughts?

  • #2


    Jeff,

    Are you able to display the current PmmC loaded on your uLCD-320-PMD2 module (using the "V" command)? If the display is loaded with the factory installed Rev2 (V command displays: "Software Rev: 12"), you may have problems trying to load PmmCs or even getting the display to recognize an AutoBaud (or any other) command using the uUSB-CE5 adapter.

    PmmC Rev6 fixed this problem. The distributor that you ordered your display from should have loaded the most current PmmC (at least Rev8) before shipment or indicated that you would have to use a uUSB-MB5 to update from the older firmware versions, and that the uUSB-CE5s that you have might not work until at least Rev6 is installed. See the Revision History at:
    http://www.4dsystems.com.au/downloads/micro-LCD/uLCD-320-PMD2/PmmC/uLCD-320-PMD2_PmmC_Revision_History.txt

    PmmC Rev9 fixes the problem with displaying images from uSD cards larger than 64MB (will not dispaly or stops after displaying first image).

    I went back through your orders and I didn't see any uUSB-MB5 purchases (only a couple of uUSB-CE5s). I also didn't see an order for a uLCD-320-PMD2.

    You have a couple of options: purchase a uUSB-MB5 (unless you already have one, in which case, just use the MB5 to load the latest PmmC instead of the CE5) that will allow you to upgrade the uLCD-320-PMD2 to the latest PmmC Rev (the uUSB-CE5 will then work fine with that display) or you can send me the display and I'll load the latest PmmC (Rev9) and return it to you ready to run.

    NOTE: The Rev9 PmmC has a bug that causes it to report to be Rev8 when using the "V" command to display version info. This bug does not effect any other Rev9 functionallity.

    Good luck and let me know what you decide,

    Steve
    Any technology, sufficiently developed, is indistinguishable from magic. A.C. Clark(RIP)

    NEW! Lower prices on all 4D Systems products for 2009 and continuing into 2010!
    http://shop.littlepcbsolutions.com

    Comment


    • #3


      I might have a related problem with my uOled-32028-PMD3t and uUSB-CE5.

      Working with the 4DGL workshop lets m,e monitor the default demo and receive the keys pressed. Trying to download a compiled program tels me the device does nort response an I should check the config.

      pmmc loader does only wait for the device while loading

      In Docklight i can receive the pressed chars but not reponse when sending something like V

      De device does go black while trying to download...

      Any suggestions ?

      Comment

      Working...
      X