Announcement

Collapse
No announcement yet.

4DPi-24-HAT: Problems with permissions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4DPi-24-HAT: Problems with permissions

    I have tried installing this so many times. It just would boot up to a blank screen.

    I finally was able to get snapshot of the issue (using burst on my Nexus 6P). I have been following the directions to a "T" from the .pdf file available online.

    The only thing I am doing different is doing all the commands in the "root terminal" rather than gaining root privileges through the normal terminal.

    I am 1000% positive that I followed the proper instructions. I assume the issue is probably in the /etc/rc.local file. I put the line "sudo - pi FRAMEBUFFER=/dev/fb1 start x &"

    Any thoughts?

    Click image for larger version

Name:	g6LAVk6.jpg
Views:	86
Size:	762.1 KB
ID:	50028
    http://i.imgur.com/g6LAVk6.jpg
    Attached Files

  • #2
    Hello gwilson

    Sorry you seem to be having problems, but the 4DPi-24-HAT looks to be working, your install just isnt doing what you want it seems.

    "sudo - pi FRAMEBUFFER=/dev/fb1 start x &"
    did you mean 'startx' rather than 'start x' ?

    and the line should be:
    sudo -u pi FRAMEBUFFER=/dev/fb1 startx &
    you seem to be missing the -u, and only have the -

    Are you running Wheezy or Jessie?

    Regards
    James

    Comment


    • #3
      Thanks for the quick reply James. That was actually a typo on my end. I am pretty sure I have the -u in there.

      I am running Jessie.

      Comment


      • #4
        Hi again

        I just downloaded the latest Jessie, installed our Kernel Pack, and all seemed fine, booted to console fine.
        I then changed the rc.local and it went pear shaped. I dont seem to get this permissions error, but maybe im missing that, but the backlight is just flashing on and off over and over.

        Reversed that, and got it to boot to the console again, all was fine.
        I then put in

        Code:
        [email protected]:~ $ startx -- -layout TFT
        
        X: user not authorized to run the X server, aborting.
        So something on this latest version of Jessie seems to have broken things.

        Looking on the release notes:
        * Included graphical package manager

        We will have to investigate and figure out what is going on.
        Can you go back 1 version of Jessie and use that instead, as that should work fine. 8-30 release I believe.


        ----------
        Actually, found a possible solution.
        http://karuppuswamy.com/wordpress/20...rver-aborting/

        Old post, but relevant I think.
        edit that Xwrapper.config with nano and change it to be anybody, or alternative run that dpkg-reconfigure command and set it via the graphical editor.
        then try and it seems to boot.

        Code:
        [email protected]:/etc/X11 $ startx -- -layout TFT
        
        
        X.Org X Server 1.16.4
        Release Date: 2014-12-20
        X Protocol Version 11, Revision 0
        Build Operating System: Linux 3.17-1-armmp armv7l Raspbian
        Current Operating System: Linux raspberrypi 4.1.10+ #16 PREEMPT Tue Oct 13 10:37:26 CEST 2015 armv6l
        Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708.boardrev=0x10 bcm2708.serial=0xaffcbf33 smsc95xx.macaddr=B8:27:EB:FC:BF:33 bcm2708_fb.fbswap=1 bcm2708.disk_led_gpio=47 bcm2708.disk_led_active_low=0 sdhci-bcm2708.emmc_clock_freq=250000000 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000  dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
        Build Date: 18 February 2015  05:34:25PM
        xorg-server 2:1.16.4-1 (http://www.debian.org/support)
        Current version of pixman: 0.33.3
                Before reporting problems, check http://wiki.x.org
                to make sure that you have the latest version.
        Markers: (--) probed, (**) from config file, (==) default setting,
                (++) from command line, (!!) notice, (II) informational,
                (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
        (==) Log file: "/var/log/Xorg.0.log", Time: Mon Dec 21 05:14:39 2015
        (==) Using system config directory "/usr/share/X11/xorg.conf.d"
        We will investigate further however.

        Regards
        James

        Comment


        • #5
          Good to know I am not crazy!!!! Haha.

          I knew I was inputting all the commands properly. I can't seem to find the last release of Jessie. Would you mind sending me to a source?

          Comment


          • #6
            A quick google search

            http://downloads.raspberrypi.org/raspbian/images/

            http://downloads.raspberrypi.org/ras...an-2015-09-28/

            However, the solution above solves it for the latest release. I just compared the previous release with the latest release, and for some reason the latest release has changed that Xwrapper.config setting. So the solution I put in the previous post is the solution to getting it working.

            Regards
            James

            Comment


            • #7
              Great, thanks!

              Comment

              Working...
              X