Announcement

Collapse
No announcement yet.

4DPI-24-HAT: Display / Backlight going to sleep.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4DPI-24-HAT: Display / Backlight going to sleep.

    Hello,

    I am using a 4DPI-24-HAT with a RPI 2. The display appears to work well.

    I am using the Pi in console mode and want it to run stand-alone - without keyboard etc. The problem I have is when the pi is left for a few minutes the 4DPI-24-HAT turns off. I suspect just the back-light is turned off to save power - is there a setting in the 4D drivers to leave the display permanently on? Without a keyboard I have no way of waking the display.

    Thanks,
    Carl.

  • #2
    Hi,

    For the console, you can try setting BLANK_TIME=0 in /etc/kbd/config.

    Comment


    • #3
      Thanks,

      Forgot to mention I already have BLANK_TIME=0 and POWERDOWN_TIME = 0 in the /etc/kbd/config file. This is how I came to the conclusion it is a setting in 4D's LCD driver package. Currently if I plug in and configure a monitor via HDMI the screen doesn't sleep, whereas the LCD module does.

      Thanks - any more help gratefully received.

      Comment


      • #4
        Hi,

        please try checking if actual setting for screen blanking is correct (should return blank timeout in seconds) :

        cat /sys/module/kernel/parameters/consoleblank

        if the timeout is wrong, here is a good link for setting blanking timeouts: http://superuser.com/questions/15234...nking-behavior




        Comment


        • #5
          Thanks,

          I checked /sys/module/kernel/parameters/consoleblanking - it showed 600. So I added the following to /etc/rc.local:

          # Stop display sleeping
          sudo /usr/bin/setterm -blank 0

          Rebooted and rechecked /sys/module/kernel/parameters/consoleblanking - 0 this time.

          My display now stays awake!

          Thanks very much.

          Comment

          Working...
          X