No announcement yet.

uLCD-43PT "Have you got an SGC PmmC loaded by mistake?"

  • Filter
  • Time
  • Show
Clear All
new posts

  • uLCD-43PT "Have you got an SGC PmmC loaded by mistake?"

    While I am a long time user of these displays, I am new to having to debug them...
    I have been using a uLCD-43PT for some projects over the last year or so along with using a few other displays such as the uLCD32-PTu and I have never had this problem with my uLCD-43PT until recently. I have been building simple interfaces with the drag and drop feature through Visi-Genie on the 4D workshop and all of my programs have worked flawlessly regardless of the display I use, but now whenever I try to load a program onto my uLCD-43PT, it always goes through all the motions as if it's loading just fine, then I get the error: "Device is not responding. Please check your configuration. Have you got an SGC PmmC loaded by mistake?"

    I have been playing around with the 4D workshop program on my own and looking for ways to update, or remove some kind of auto update from my PmmC, but I keep coming up short. My computer still programs all of my other displays with no problem. How do I fix this?

  • #2
    What is on the display's screen when it is powered up? Is this expected? Is the backlight on?
    What PmmC version has is loaded? (click on the traffic light in the comms tab in workshop and see what it comes back with after a few seconds)


    • #3
      Display turns on and just displays "drive not mounted..." when the SD card isn't in it and when I put the SD card back in even after attempting to load a new program on, it just continues to display the previously loaded program from another project.


      • #4
        Everything still seems to work fine, it simply won't finalize the new program to the display without showing that error message. I have tried using several other computers to load programs on with and it's the same result every time. Is there some kind of software update for the screen itself I need to load on to it first?


        • #5
          Please try and answer all the questions asked.

          Since you have answered the first bit, when you click on the traffic light (with the uSD removed and 'Drive not mounted' is displaying) does the display go blank for a second or two before the 'drive not mounted' returns (and since it does that cyclically please make sure it is blanking to the clicking of the traffic light, not just the cyclical action).


          • #6
            Upon plugging the display into my USB port without the micro SD card being mounted in the display, the process is this: a white flash, then immediately after, goes to the black screen with "Drive not mounted..." flashes about once every second. I'm not sure exactly what you mean by "make sure it is blanking to the clicking of the traffic light, not just the cyclical action"


            • ESPsupport
              ESPsupport commented
              Editing a comment
              Yes, it flashes once every second, 'normally'.
              If the comm port is set to the comm port attached to the display, and you click on the traffic light, the display should blank for about 4 seconds, then display the 'Mounting...' message, before starting the 'Drive not mounted...' cycle again. Is this happening? (maybe make a short video?)

          • #7
            Are you using a Programming Cable, or a uUSB-PA5?
            It is just directly connected to the display, correct? Nothing else is connected?
            Please describe how you have it attached.
            To have it load an old program after you reprogram it, suggests it is not being programmed successfully.


            • #8
              Programming cable.
              Programming cable attached to wires that are directly and cleanly soldered onto the display's TX, RX, GND, 5V, and RST pins.
              Exactly my problem.


              • #9
                Are you able to make a little video of you programming it, and upload it somewhere where we can see?

                Clicking the Traffic Light in WS4, does it always just show that PmmC / SGC warning?
                Have you tried doing a PmmC update? Does it succeed or does it fail?

                Do you power the display normally from your computer, or is it normally powered from an external supply? When you program you obviously use the cable, and is that when you have the problems. Are you on a laptop or a desktop?


                • #10
                  Another this to check is your Programming Cable. Please examine the little wires at the end of the plug which goes into the display. Are all the wires intact?



                  • #11
                    Here is a video of what's going on. I tried to explain the process and problem as best I could in the video


                    • #12

                      Thanks for the video.

                      Ok on the back of the display, you have the 5 way cable going onto the display 10 way header I assume?
                      What side of the header are you using? Both should be connected the same, but just curious if you try the other side. I wonder if there is a dry solder joint or something and its preventing connection to the header.
                      The cable you are using, you have an extension on it by the looks? (hard to tell as its so dark in your video). I assume you have tried it directly on to the cable?

                      Typically when you get that error and the red Traffic Light, you click the red dot and it will reset the display and scan the serial port, and it should change colour and detect the display.
                      So if you remove that 43PT and just put on one of your other displays, that is detected fine right?
                      If so, maybe just check the header on the display and check the solder joints and see if you can spot anything obvious.

                      The signals on the cable that go onto the 10 way header, are also available on the 30 way header. You just need to individually connect to them, they are not right next to each other. You could try that too and see if you can program via the 30 way header, as that would further confirm something is up with the 10 way. If its the same then there is something more going on.

                      Let me know

                      *EDIT* - and FYI, the 'SGC' is an old (and no longer supported) separate PmmC from a few years ago, which was our Serial Platform. So like our Serial Environment is now, with SPE, the SGC was the old version of it. It was a separate PmmC which you loaded specifically for Serial. So it comes up with that warning typically if the PmmC is not responding to Workshop, as SGC would not respond to Workshop in the intended way. Just some context.



                      • #13
                        I am using a display that was gently used before I got it, but the original pin headers have been removed and I simply soldered my wires straight to the points where the headers were originally placed. I have now tried programming with the wiring soldered to both sides of the 5 pin connectors on the screen with the same result. Even after I cleaned up the solder connections on both sides. I have not tried directly soldering the programming cable directly to the screen 5 pins yet, simply because I am confident in the quality of my wire extension between my display and the programming cable.

                        The red Traffic Light does not change when I click it to reset this display. I have not had a chance to try another display yet to see if the traffic light will turn green, but as I recall, it has always been red no matter which display I connect.

                        I have not tried connecting to the 30 way connection pins yet, but I did try connecting to the J2A pins and still the same results.

                        I've understood most of what PmmC was for in other uses of older hardware, but what makes me really stumped here, is that the display used to always program just fine about a month ago. Nothing changed on my computer since it worked. Could the processor on the screen simply be dying?


                        • #14
                          Hi again,

                          J2A - so you have some quite old hardware then it seems. What revision is the hardware?

                          So regarding your wiring you have soldered on, this is only to J2 right? You have nothing connected to J1 at all?

                          The red indicates a problem, and it should not do this for any display you have unless its not connected. If its OK it should be Blue. Please check on another one of your displays using the same cable, if they also do this? This is important to know, if its limited to one display, or if all your displays do it. If they all do it, then its likely a driver problem or something else weird with your setup.

                          What version of the Programming Cable driver are you using? You are using Windows 7 right?



                          • #15
                            Well, this is kind of embarrassing... My problem was that I was connecting the TX pin on my display to the TX wire header on my programming cable and same for the RX to RX pin.
                            The correct connection is RX to TX between the cable and the screen. I never realized this because I always connected the programming cable directly onto the header on the back of my other screens. Using my wire extension was what got me confused.

                            Hopefully this forum will help others avoid this I. D. 10. T. error