Announcement

Collapse
No announcement yet.

4DPi-32 needs to manually startx everytime

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4DPi-32 needs to manually startx everytime

    I have a 4DPi-32 connected to RPi B+. I have updated kernel to support the display module, but after each booting, I need to start a VT and start GUI for the display. HDMI is still working fine. How can I automate this.

    I have added "sudo -u pi FRAMEBUFFER=/dev/fb1 startx &" in my rc.local, but for no use.

  • #2
    Hi,

    Can you please give more information about the current version of RPi compatible linux distribution installed.
    Please use the 'uname' command to get all system related information. Also, please share a copy of the device's boot log - use 'dmesg' and save to file.


    Regards,

    Comment


    • #3
      Hi Bryan,

      Thanks for your response.
      current version as per uname is
      >> Linux raspberrypi 3.12.20+ #96 PREEMPT Tue Aug 12 09:30:50 CEST 2014 armv6l GNU/Linux

      Here is the boot log ->. version_boot_log.txt

      Comment


      • #4
        Hi Azeema,

        Please try the following steps. We have to go through the process so we have the identical setup.

        ** Please detach the 4DPi-32 before proceeding to the following steps.

        1. Write a fresh copy of the Raspian image on microSD
        2. Update the system (Please do not skip this step) : 'sudo apt-get update'
        3. Download the 4DPi-32 installer package : sudo wget http://www.4dsystems.com.au/download...10_v1.0.tar.gz
        4. Unpack the package: sudo tar -zxvf 4dpi-3x_4-1-10_v1.0.tar.gz -C /

        5. Edit /boot/config.txt file change to the following config.

        #uncomment if running on RPi2
        #kernel=kernel7_hat.img

        #uncomment if running on RPi1
        kernel=kernel_hat.img

        6. Shutdown RPi.
        7. Attach the 4DPi-32 to RPi and apply power.

        ** Following the above steps, there was no need to modify rc.local.
        ** In the event that the process does not have the same result. Please use the raspi-config utility to change the boot options.
        - B4 Desktop Autologin Desktop GUI, automatically logged in as 'pi' user

        ** A portion of the boot sequence should be visible. It takes a little while for the Raspbian Jessie to show its desktop.

        Regards,


        Comment


        • #5
          Hi Bryan

          Thank you so much..
          It worked

          One minor issue. After I shutdown the system, the display remains on till I disconnect the power. Why is it so?

          Thanks & Regards
          Azeem

          Comment


          • #6
            Hi Azeem

            That is because when the Pi shuts down, it doesnt tell the display to display anything different, so it keeps displaying what it was last told to display. It has its own processor on board, so retains the picture of what was last sent by the Pi. Power cycling will reset the displays processor so it disappears.

            This is why it does this.

            I will check with the software developer of the 4DPi if there is a way to send a command to blank it prior to shutting it down.

            Regards
            James

            Comment


            • #7
              Hi James

              Thanks for sharing the info.

              Please update if you get to know about some methods to turn off/black out the display.

              Regards
              Azeem

              Comment

              Working...
              X