Announcement

Collapse
No announcement yet.

Problems with Workshop 4.2.0.16

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with Workshop 4.2.0.16

    I used to Workshop 4.1.x with Picaso. Workshop 4.1.x does not support uLCD43-DCT. Now, I tried to use Workshop 4.2.0.16 for uLCD43-DCT. When I press compile button it compiles. Then it ask sd card loading. After I select Yes or No, Workshop IDE does not work. Blue circle is spinning and IDE freeze. So, Workshop4 is not responding anything.
    I close with Task Manager. After it closed but I see "4dcompiler.exe *32" (CPU-> %25). When I try one time same things happens.

    I must use uLCD43-DCT but I do not use my project with uLCD43-DCT. Please help urgently. (Maybe I use 4.2.x old version but any setup file in website).

    My computer: Windows 7 Enterprise/SP1, i5-4460, 8GB RAM, 64-bit OS.

    In addition;
    I try Toshiba laptop; Windows 8.1, i7-4710, 16GB RAM, 64-bit OS. There is same problem.
    Last edited by Safak_hvl; 26 February 2016, 09:25 PM.

  • #2
    There is a bug in the compiler that might be causing it to loop.

    If there are accented characters in the code, especially the comments, the compiler can loop, this will cause the issues you are experiencing.

    Please check your code and if you can't spot the issue please send the source to mark at 4dsystems dot com dot au (use file zip project)
    Mark

    Comment


    • #3
      I checked my code but there is a lot of non-english character in comments. If I will changes characters, it takes too long time. Is there older version IDE any URL? Only one important thing which is support ULCD-43DCT. Latest version is not necessary for me.

      I can't send code. In addition, my code is huge for ulcd. There are 110931 characters with 2560 line.

      Or, when new version of IDE will release?

      Comment


      • #4
        I checked my code but there is a lot of non-english character in comments. If I will changes characters, it takes too long time. Is there older version IDE any URL? Only one important thing which is support ULCD-43DCT. Latest version is not necessary for me.

        I can't send code. In addition, my code is huge for ulcd. There are 110931 characters with 2560 line.

        When new version of IDE will release? or If I buy PRO version, same bug will be solved?

        Comment


        • #5
          No, the only way to fix it is with a fixed compiler version.

          Try the attached, un zip it and replace the compiler in C:\Program Files (x86)\4D Labs\4D Workshop 4 IDE\DEP
          Attached Files
          Mark

          Comment


          • #6
            I did it. It works correctly. Thank you.

            Comment

            Working...
            X