Announcement

Collapse
No announcement yet.

4DPi-24-HAT with Raspberry pi 3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4DPi-24-HAT with Raspberry pi 3

    I have just bought a new Raspberry pi 3 and loaded it with the latest Jessie. It works fine and boots to the GUI really fast. I already had a pi2 on wheezy.

    Bought a 4DPI-24-HAT and followed the instructions in the enclosed leaflet. It did not work. The RPi would not boot. I had to reflash a new Jessie image - twice. I then I found out on this forum that the instructions are out of date. Not impressed​.

    Downloaded the pdf file on this website and followed the new instructions. The package downloaded OK and installed as far as I can tell. I left it configured for a pi2 as there is no mention of a pi3.
    I added

    -u pi FRAMEBUFFER=/dev/fb1 startx &

    to rc.local

    then I shutdown, fitted the display and rebooted without the hdmi monitor.

    Partial success! This time the CLI scrolls startup code but then the screen flashes on and off but goes no further. No GUI.
    Can anyone advise how to get it working with a pi3 ?


  • #2
    Addendum:
    I have got it to work by booting just to the CLI.
    Fresh jessie image, download and install files again. leave rc.local unaltered and set pi to boot to CLI.
    Can't start GUI. Tried startx and I get an error message.

    Comment


    • #3
      Hello Dave3d

      To start with, the Pi3 is new, we dont have one and we have not stated support for it anywhere - there is that issue.
      Forum instructions - unsure what you are referring to, but check the date of the post and that should give you some indication if its relevant or not.
      The Kernel for the 4DPI-24-HAT is for the Pi1's and the Pi2, it states nothing about using it for a Pi3, likewise for our instructions.

      So please, give us some consideration when you say things are wrong or out of date, if you are using the latest version of something. The Raspberry Pi is one of many products we make displays for, so keeping up to date with every latest change that comes out, you need to allow some time.

      Please provide the errors you are getting and we can try and assist, but you need to take the above into consideration.
      Being on the bleeding edge, you might want to consider taking the source code and compiling your own kernel etc which might give you more success for something so new as the Pi3.

      I don't know what more I can say, given the information you have provided.

      Regards
      James

      Comment


      • #4
        Hi Dave3d

        not sure what went wrong. I have just tested 4DPI-24-HAT with RPi3, and everything works, including on board WiFi (haven't tested BLE).
        -install the newest Raspbian, dated 2016-02-26 (https://downloads.raspberrypi.org/raspbian_latest)
        -login, expand file system...
        -get kernel with 24-HAT drivers (wget http://www.4dsystems.com.au/download...10_v1.0.tar.gz)
        -install downloaded package (sudo tar -xzvf 4d-hats_4-1-10_v1.0.tar.gz -C /)
        -reboot - many files were written to SD card, so clean reboot is required! (sudo reboot)
        ---
        after a while RPi3 rebooted, 24-HAT was working normally

        Comment


        • #5
          James:

          the pi 3 has been out for a little while now and I was surprised there is no mention of it in any of your literature. I was talking about the pdf data sheet I downloaded from your website. Fair enough if it is not supported or incompatible it should say so. I will know better next time. Your comments are not particularly helpful.

          strancara:

          Thanks for the reply. I have done exactly what you said.
          I installed a fresh Raspian jessie image (the full version) from the same source and downloaded the kernel and 24-HAT drivers from the 4dsystems site.
          It will not boot to a GUI. I can get the display to work if I reboot to a CLI only. I then tried raspi-config from the CLI to try to boot to the GUI but it will not work.
          The latest jessie seems to use xfce rather than lxde so startx will not work. Did you alter any other files such as rc.local ?

          Comment


          • #6
            Hi Dave3d,

            I did only and exactly the described steps and ended in LXDE GUI after reboot.

            -loged in as pi via ssh
            sudo raspi-config
            #expanded file system, nothing else
            sudo reboot
            wget http://www.4dsystems.com.au/download...10_v1.0.tar.gz
            sudo tar -xzvf 4d-hats_4-1-10_v1.0.tar.gz -C /
            sudo reboot

            ---
            for manually starting/stopping LXDE you can use

            sudo service lightdm start
            sudo service lightdm stop

            this also works (useful if you wish to start the GUI on HDMI):
            sudo startx -- -layout TFT
            sudo startx -- -layout HDMI

            RPi3 (released five days ago) is compatible with RPi2 so until there is a 64 bit kernel for the RPi3, there is nothing to support regarding display drivers. Even if you stick a SD card with a RPi2 image into RPi3, it should work (minus on board WiFi/BLE support).

            Comment


            • #7
              That works ! Thanks strancara.

              I installed a fresh jessie image, got the wifi working via GUI then set it up to boot to CLI. I then did all the installation via CLI.
              The secret seems to be sudo reboot. Also I thought the GUI was xfce when it is actually lxde. I should have checked.
              The commands you listed work OK, I can switch between HDMI and TFT which is really handy.
              I must have spent 6 or 8 hours trying to get it to work.

              Also FYI I have got a pi 2 as well but if I put the SD card from it into the pi 3 it will not boot. The pi3 is quite a bit faster.

              A minor point, but the display needs standoffs under it. At the moment it is just plugged into the GPIO socket and flexes.
              Are there special standoffs or do you just use computer motherboard standoffs? I am using the official pi 3 case.

              Comment


              • #8
                Hi Dave

                Please see section 4.1 of the Datasheet, which talks about the standoffs. We dont supply standoffs, but these are easily obtained. Have a quick google and you should find a local supplier.
                M2.5 thread and the body should be 11mm in length. Many places sell generic standoffs, and if you google you can find many places who sell ones titled as 'Pi HAT Standoffs'.

                One suggestion listed in the Pi documentation is:

                Mouser Part #: 761-M1258-2545-SS
                Manufacturer Part #: M1258-2545-SS
                Manufacturer: RAF Electronic Hardware
                Description: Standoffs & Spacers 11mm METRIC STANDOFF


                I hope that helps. If you google some more, you will find many other types which people have found which work well.

                Regarding your comment:
                the pi 3 has been out for a little while now and I was surprised there is no mention of it in any of your literature
                Fair enough if it is not supported or incompatible it should say so
                If something is not supported, you shouldnt expect it to say so as that would imply the documentation is updated immediately when something is released.. Rather think the other way, and if it says the Raspberry Pi 2 is supported but doesn't mention the 3, then assume the 3 is not specifically supported.

                In this case, as Strancara has mentioned, the Pi3 works off the default image, as you have also seen. We will be releasing a newer image in time which supports the Pi 3 better, as more information is made available. As Strancara said, the Pi3 has only been out about 5 or 6 days, so you really are right on the edge in terms of getting support for this.

                I am glad it is working for you now though.

                Regards
                James

                Comment


                • #9
                  Hi,

                  I also tried to get my 4Dpi-24-HAT to work with my Raspberry Pi3. It always worked like a charm except for one thing : bluetooth.

                  On a fresh install (NOOBS latest 1.9.0) the builtin bluetooth is recognized and I can pair with an external device by using bluetoothctl. Everytime I install the 4Dpi-24 kernel with the suggested command (sudo tar -xzvf 4d-hats_4-1-10_v1.0.tar.gz -C /), the builtin bluetooth is no longer recognized whether I'm using bluetoothctl or blueman.

                  Any advice ?

                  Regards.

                  Comment


                  • #10
                    Hi Woocarz,

                    Welcome to the forum.

                    I believe the Pi3 kernel source hasn't been released yet (last I was told by our 4DPi developer), which was eluded to in Post #6.
                    This may be available now, I am not sure. When/if it is, he will start developing a new kernel release, but until then its a bit hard for us to provide a new kernel if we have no source code.

                    Watch this space.

                    Regards
                    James

                    Comment


                    • #11
                      New 4DPi kernel pack has been released which better suports the Raspberry Pi 3.

                      This can be downloaded from our product page, and is also updated in the Datasheet.

                      Using 4.1.19 Kernel now also, updated from 4.1.10

                      http://www.4dsystems.com.au/download...19_v1.0.tar.gz

                      Regards
                      James

                      Comment


                      • #12
                        Hi i just signed up, and i want to buy an 2.4" inch touchscreen for my Raspberry Pi 3B. I Searched alot but most touchscreen are for the old Raspberry 1 and 2. Can this 4DPi-24-HAT work with my Raspberry Pi 3B? I see here mixed answers.

                        Comment


                        • #13
                          Hello Oxize

                          Yes it works fine with the 3B.

                          Refer to the current datasheet on our website, it states Pi3 support.
                          Download the latest kernel pack for it, and you should not have a problem

                          Regards
                          James

                          Comment


                          • #14
                            Hello, I want to know if a display similar to 4D-24-HAT but using the display connector (not GPIO) on Raspberry Pi-3b will be able to work with Windows IoT Core for it, and when it will be available with the display drivers for it?

                            Comment


                            • #15
                              Hi, i cant get my hat to work. I am using noobs and raspbian, and raspberry pi 3b. But after i have done what you said, it will only show up on my tv, from my hdmi cable. And if i boot rasbpian then the screen on my tv goes black But when i go on recovery/noobs then it shows up on the tv. What do i do?
                              Last edited by ubuntulover; 20th August 2016, 10:12 PM.

                              Comment

                              Working...
                              X