Announcement

Collapse
No announcement yet.

Device is not responding

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    That's the problem. Eventhough it's working based on the test, the workshop still said "Device not responding" when I tried to program the LCD.

    The connection was as I mentioned. I've tried Tx (programmer) - Rx (LCD) and Rx (programmer) - Tx (LCD). I've also tried to switch them. Both are not working.

    Click image for larger version

Name:	20160531_101531.jpg
Views:	30
Size:	28.6 KB
ID:	52856 Click image for larger version

Name:	20160531_102104.jpg
Views:	30
Size:	58.5 KB
ID:	52857
    Attached Files

    Comment


    • #17
      Yes, it is directly from DTR to Reset. I also hope I didn't destroy the LCD.

      Comment


      • #18
        well that is never going to work...
        James

        Comment


        • #19
          See this thread http://forum.4dsystems.com.au/forum/...-usb-to-serial
          Mark

          Comment


          • #20
            It worked before when I connected them directly. What do you mean with it's never going to work? Is it going to destroy the LCD if I don't connect it via transistor? May I know the purpose of using the transistor?

            Edit: I'll try to add the transistor. I'll tell you again the result after I finished it.

            Thank you.

            Comment


            • #21
              Well the reason why its in our programming hardware, is it is required and is there for a reason.
              We wouldnt just put components on a board if they were not required.

              The capacitor is there to block DC signals and basically act as a pulse transmitter, which is then cleaned up by the transistor and inverted to suit the processor. So when DTR changes state, it is changed into a pulse, and the display is reset at the right time in the programming sequence.
              Not having it, I have no idea how the processor will interpret it, but more than likely it will not be reset at the right time, or it may even be held in reset, etc.

              This is why we say you cannot just use any old programmer, and you should buy genuine 4D programming hardware to program 4D products. Our hardware has specific requirements in order to program it, so using generic is never encouraged, especially wiring it incorrectly.
              James

              Comment


              • #22
                I've tried adding a circuit based on the picture from the link you gave me. In the end, I bought a new LCD again. When I tried to use the new PA5-II for my old LCD, "device is not responding" still appeared. I think I really did break it.

                Later, I used my new LCD. It is the same type: ulcd 70dt. I have a question about it. I'm not sure if I can just ask here or should I use move to a different topic. If I touch the winButton, it often returns -1 instead of its index. After some trials, it seems the location of the button is not at the same location as the button image. For example: I put the button image at x = 400 and height = 40. If I touch on x = 400 ~ 420, it returns -1. But if I touch below 420 until around 460, it returns its index. However It doesn't always happen that way. If I put it on the upper center part, it seems the button is higher than the image itself. If I put it on the center, it works fine.

                Thank you again for your help.

                Widya

                Comment


                • #23
                  Try running the touch calibration program from the tools menu
                  Mark

                  Comment

                  Working...
                  X