No announcement yet.

uLCD43PT-AR's serial port not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • uLCD43PT-AR's serial port not working

    The display suddenly stop communicate thru serial port when connected to arduino or PC.

    The installed Pmmc version that I had and everything worked well was uLCD-43PT-R36.PmmC. The program that I download to lcd and was written thru workshop IDE was running ok and serial port worked nice.I was having Workshop IDE and i decided to install workshop IDE When I connected the screen it download thru workshop IDE the new (pmmc uLCD-43PT-R44.PmmC) . I download the program from Workshop IDE to the lcd that was working fine with the previews version of IDE and now the screen when be connected to the PC or arduino not responds to serial communication even IDE searches for the port COM5 that is available to pc for usb connection to the uUSB-PA5 and to the screen. The red light to the uUSB-PA5 is blinking but no communication with the screen. I connected the +5V to +5V GND to GND and TX to TX and RX to RX. I also tested with another uUSB-PA5 that I have and also tested both of the communication ports of the screen J2 pin outs. 1,3,5,7 but also 2,4,6,8. No communication with the IDE. I also put the old version of workshop IDE back again I also tested with Pmmc Loader and it says

  • #2
    Access denied retry in 5 seconds


    • #3
      but nothing happened. When I try to communicate with pc no sdcard is in the lcd. So the mount message appears.Is there a way to fix this?


      • #4
        I asked you to (when you emailed me) to do the following:-[INDENT]Also search the forum first to see if there are some hints on what to do and what to test


        Most people are using, so there


        • #5
          I searched the forum i saw the and i also reversed the TX & RX but nothing happened its still the same Serial port not working.


          • #6
            Sorry, focus on getting Workshop to talk to the display.... and do what I asked.

            I can't see how you can reverse TX and RX when using the PA5.

            Actually, when using a PA5 I can't see how you can connect it properly to pins 2,4,6,8 of J2, the board will be in the way, it can only connect to pins 1,3,5,7, at least it can only connect there the right way around.


            • #7
              Mark I did connected the display it should be but it doesn't communicate the Serial port of the screen.


              • #8
                Please tell me where to send the display for check and replacement.


                • #9
                  check device manager to see if it shows up as a com port before you start blaming the application, also the uUSB-PA5 must be connected to lcd BEFORE you plug the USB CABLE into your PC, or else it wont work.
                  Last edited by tonton81; 17 May 2016, 01:46 AM.


                  • ESPsupport
                    ESPsupport commented
                    Editing a comment
                    That's not true, you can connect things in any order.

                • #10
                  I know tonton81. In device manager of Windows 7 you see the Serial port com5. Also the uUSB-PA5 is connected to the display and after that i connect the USB cable to the uUSB-PA5. The Red led on uUSB-PA5 is blinking but in Workshop IDE it says there is not any display connected.


                  • #11
                    okay thats good, try to open workshop IDE, 4.2 that you should be using, so am I. goto the COMMS tab, tell me if you see a blue or red DOT, also see if your COM port is listed beside it.

                    Next, goto the Projects tab, set your com port there, use 57600 for now as a test.

                    Goto File, Options, Genie tab, set the same baud rate there, 57600 and click OK.

                    Click HOME tab, save your project.

                    go back to the COMMS tab, tell me what you see there, if it's still RED, click on the RED so it can scan that selected PORT again.

                    When it turns blue, I can give you more things to do.
                    Last edited by tonton81; 17 May 2016, 02:49 AM.


                    • #12
                      I use the Workshop IDE . I changed the baudrate to 57600 and i clicked on the comms the color is Red and when i click the Red and scanning it says "comm port not currently available"


                      • #13
                        but you can see the COM5 there as it is in device manager.For Communication with the uUSB-PA5 i use the CDM v2.08.28 Certified drivers in Windows 7 and the led is blinking in uUSB-PA5.


                        • #14
                          I think that something is broken in electronics of the uLCD43PT-AR in the Serial port and nothing can change this. But it was working and suddently stopped after this firmware upgrade.


                          • #15
                            so you updated the PMMC for the new workshop IDE and now your using the old IDE?

                            That might be your issue. Install the latest workshop 4.2