Announcement

Collapse
No announcement yet.

4DPi-24-HAT on Zero

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4DPi-24-HAT on Zero

    I have a problem. i have set up a brand new SD-Card with the latest Image from Raspian (jessie). I configured the W-Lan via W-Lan-Stick and conected to the Zero via Putty.
    Then i updated Raspian by sudo apt-get update,sudo apt-get dist-upgrade, and sudo rpi-update. After rebooting i downloaded the latest Kernel from http://www.4dsystems.com.au/download...19_v1.0.tar.gz and installed it by "sudo tar -xzvf 4d-hats_4-1-19_v1.0.tar.gz -C /". Because i am using a Zero ive changed the boot config.txt to kernel_hat.img ....

    And now the Zero wont boot.... what can i do?

  • #2
    Hello Grobi,

    Its because the latest Raspbian Build is using 4.4 Kernel as our Kernel pack was using 4.1.19

    A new kernel pack has just been uploaded.

    Raspbian builds change so fast its hard to keep up sometimes.

    Please try this download. Datasheet instructions have been updated with this link also.

    Code:
    http://www.4dsystems.com.au/downloads/4DPi/All/4d-hats_4-4-9_v1.0.tar.gz
    Regards
    James

    Comment


    • #3
      Great! I will try the new kernel as soon as im at home....

      Comment


      • #4
        The Diplay works fine with teh new Kernel pack. But now i have another problem: After booting the display shows me an Login-screen. When i enter my username and my password the display starts blinkin a few times and the it shows me the Login-Screen again....... when i enter an incorrect password, it says "password incorrect".

        Is it somehow possible to boot the display to the normal konsole?

        Comment


        • #5
          This is what i see and from where i cant go further....

          Click image for larger version

Name:	20160525_220848.jpg
Views:	82
Size:	775.4 KB
ID:	52745



          and this is what i want to see.....

          Click image for larger version

Name:	Konsole.jpg
Views:	113
Size:	40.3 KB
ID:	52746


          how can i do this?

          Comment


          • #6
            Hi Grobi

            Would you not use raspi-config and set it up to auto login, or to boot to console rather than boot to gui ?

            Regards
            James

            Comment


            • #7
              Hi James,

              i have tryed to set Raspian to boot to console with auto-login, but then the Zero stoped booting at this point:

              Click image for larger version

Name:	20160526_101436.jpg
Views:	94
Size:	4.43 MB
ID:	52766

              Comment


              • #8
                So you downloaded a fresh version of raspbian, set up your wifi, you then did an update on it, you then downloaded the latest kernel pack we provided, tried to set up auto login, and its not booting at all?

                Something seems odd as others have reported it working fine...
                Did you start again after installing the old kernel pack, when you then installed the latest one? or did you just put it over the top?
                James

                Comment


                • #9
                  Originally posted by James_4DSystems View Post
                  So you downloaded a fresh version of raspbian, set up your wifi, you then did an update on it, you then downloaded the latest kernel pack we provided, tried to set up auto login, and its not booting at all?
                  The Zero boots, but on the Display it stops at the shown point. Using Putty i can get access on the pi.

                  Originally posted by James_4DSystems View Post
                  Something seems odd as others have reported it working fine...
                  Did you start again after installing the old kernel pack, when you then installed the latest one? or did you just put it over the top?
                  I imaged my wifi-ready-system and startet from this image with the new kernel-pack.


                  Is there any opportunity to configer the 4d-24-HAT that way, that is allways shows the same thing as the HDMI or PUTTY?

                  Comment


                  • #10
                    Are you making the Pi boot to the right framebuffer?
                    This is covered in the Datasheet.

                    Code:
                    startx -- -layout TFT
                    or

                    Code:
                    FRAMEBUFFER=/dev/fb1 startx
                    James

                    Comment


                    • #11
                      Hi Grobi,

                      this message suggests that there is a problem with file system:

                      No directory, logging in with HOME=/

                      After installing the kernel package, did you do a clean reboot (sudo reboot)? Reboot can take quite long after installing the package, since many files have to be written to SD card.

                      Comment


                      • #12
                        Today i have donn everything from the beginning:

                        -flashed a brandnew Raspian Jessie immage on my SD-Card.
                        -changed the local-settings tho my country
                        -set up the wifi-connection
                        -reboot
                        -update
                        -reboot
                        -dist-upgrade
                        -reboot
                        -rpi-update
                        -reboot
                        -set via raspi-config to boot to console (autologin)
                        -reboot
                        -downloaded the new 4d-Kernel-Package
                        - installed the Kernel-Package
                        -changed the config.txt tho kernel_hat.img
                        -shutdown
                        -plugged the Display on
                        -disconectet the HDMI cable
                        -power on
                        -nothing on the display, LED on Zero blinking.......

                        -switched off power
                        -disconnect the Display
                        -connect th HDMI Cable
                        -power on
                        -Zero boots to the console

                        -changed via Raspi-Config to boot to GUI (autologin)
                        -reboot

                        -nothing but a blinking cursor in the upper left corner.........


                        perhaps i have shot my display?




                        Comment


                        • #13
                          i have tried something else:

                          -pluged the Display on the Zero
                          -let the HDMI cable conected
                          -power on
                          -watch the Zero booting on the TV but nothing is shown on the display
                          -while booting the Zero says: " Failed to start /etc/rc.local compatibility" what does this mean?

                          Comment


                          • #14
                            by the way: i am not able to start the gui via startx from the console.

                            it says: " unable to connect to x server: connection refused"....

                            Comment


                            • #15
                              Hi Grobi,

                              I have tested the 24-HAT drivers with RPi1; after flashing a SD card with the newest Raspbian image please try these commands (I did nothing else, and it resulted in a working image)

                              Code:
                              wget http://www.4dsystems.com.au/downloads/4DPi/All/4d-hats_4-4-9_v1.0.tar.gz
                              sudo tar -xzvf 4d-hats_4-4-9_v1.0.tar.gz -C /
                              sudo nano /boot/config.txt # select kernel_hat.img
                              sudo reboot

                              Comment

                              Working...
                              X