No announcement yet.

4DPi-24-Hat Rainbow Screen

  • Filter
  • Time
  • Show
Clear All
new posts

  • 4DPi-24-Hat Rainbow Screen

    Hi, I followed the guide to do some config.

    After I changed about /boot/config,txt and rebooted, it stuck in the rainbow screen.

    What did I go wrong?

  • #2
    Hello DevilMoo

    Welcome to the forum

    My guess would be you are loading the wrong kernel for your RPi. RPi 1's (A, B, B+ etc) have one kernel, and Pi2 and Pi3 have another kernel.
    Please have a look over the instructions again, as it is mentioned in there, what you need to comment out in config.txt

    If this is not the case, reply back, but do provide more information about what you RPi you have, and what you have configured in config.txt

    Also please detail what instructions you are referring to, and what kernel pack you are using (what did you download).



    • #3
      I changed the kernel7.hat to kernel.hat.
      And my sd card free space is only about hundreds MB. Is it related?


      • #4
        Hello DevilMoo,

        Thank you for your inquiry and for your interest in our solutions.

        I forwarded your inquiry to my colleagues , Ferdinand. and Genesis. Please see their reply below.

        hi DevilMoo,

        thank You for your interest in our products.

        After changing the kernel from Kernel7.hat to kernel.hat, does the display boot up?

        What System did you use to see the information of your SD Card?

        The SD card is automatically formatted into three partition after you put raspbian OS on it.
        If you try to insert your card to a windows system, you can only see the partition formatted as FAT32 File system and the other partitions are formatted in linux file systems and you can see it in windows system.


        Ferdinand and Genesis



        • #5
          It is okay now because last time I did not delete the image completely.

          Now I fix 99-calibration.conf following

          Section "InputClass"
          Option "Calibration" "119 3736 3850 174"
          #Option "SwapAxes""1"

          After reboot, it says "3736" is not a valid keyword in this section.

          How do I fix it?


          • #6
            Hi DevilMoo,

            Good Day,

            I see that you copy the exact code of the step 5 in Calibrating the Touch Screen. The one that you must put on the 99-calibration.conf should be the values that you get after you finished calibrating your screen.

            Did you do the steps in Calibrating the Touch Screen?

            If yes, copy that values you get after doing step 4 to the 99-calibration.conf file and save it.

            if not, Install xinput-calibrator first before doing the steps in Calibrating the Touch Screen, to install. Open the terminal and type:

            sudo apt-get install xinput-calibrator

            when installation is done. Proceed step 1 to step 4 in Calibrating the Touch Screen. It should give you the values that you will put on the 99-calibration.conf.




            • #7

              why do I have to copy the values into 99-calibration.conf rather than using the xinput-calibrator one?


              • #8

                Hi DevilMoo,

                Good Day,

                When executing the xinput-calibrator, and followed the direction on the screen it will generate information of the calibration that you make. You need to put that generated information to the 99-calibration.conf to save the configuration so that after you reboot you dont need to re-calibrate again.