Announcement

Collapse
No announcement yet.

4DPi-32 v2 Rotation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4DPi-32 v2 Rotation

    Hi,

    I'm using a RPi 2 with raspbian 8.

    I have pluged a 4DPi-32 v2 and it appears to be rotated 180

    I edited the cmdline.txt and typed 4dpi.rotate = 180 but nothing happened; also if I typed = 90.

    I tried " cat /sys/modules/4dpi/parameters/rotate " but it seems there is a bug in the datasheet; it doesn't exist "/modules/" but it does "/module/". Using "cat /sys/module/4dpi/parameters/rotate" I get 180 no matter what I write to cmdline.txt

    Any idea?

    Thanks in advance

    EDIT : SOLVED. I typed 4dpi.rotate = 0 in the cmdline.txt and it works. It is OK now. It appears it comes rotated 180
    Last edited by Colomer; 21 July 2016, 03:46 PM.

  • #2
    I was confused with another old unit. It is NOT SOLVED. No matter you type in cmdline.txt, the display comes with a 180 degrees rotation.

    When I connect via vnc, in the other computer I see everything in the normal position.

    Is there any other way I can change the rotation?
    Last edited by Colomer; 22 July 2016, 02:16 PM.

    Comment


    • #3
      Hi Colomer

      I assume when you are typing this into cmdline.txt, you are restarting your Pi for the changes to take effect?
      If you have done that, and its not working, ill get someone to investigate further.

      Regards
      James

      Comment


      • #4
        Yes, I reboot the RPi, but no changes at all after rebooting.

        Comment


        • #5

          Hi Colomer,

          Good Day,

          Thank you for using our products.

          You should change the permission of the file rotate. So that you can edit the file.
          To change, open terminal:
          cd /sys/module/4dpi/parameters
          sudo chmod 777 rotate
          sudo reboot

          then, go back to cmdline.txt and change 4dpi.rotate=0 or 90,180,270


          Regards,

          Ferdinand

          Comment


          • #6
            I did what you tell me but it still don't work...

            The problem is that I change the permisions to the file. It doesn't give any problem and after changing them, I do a ls -l and I see it has the permisions right. But after the reboot they return to read only mode.

            Any idea?

            Thanks in advance
            Last edited by Colomer; 28 July 2016, 02:33 AM.

            Comment


            • #7

              Hi Colomer,

              Good Day,

              Yes, I also notice that it will go back to read only mode. Go to cmdline.txt and change the rotation 4dpi.rotate=90.

              On the Terminal, using SSH
              sudo nano /boot/cmdline.txt

              The file cmdline.txt will be open and at the end of the line Add, 4dpi.rotate=90

              dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait 4dpi.rotate=90

              Save and reboot. The display orientation must change.

              Every time you change the rotation, you must reboot to apply the changes that you made. You can also check the file rotate, to see if the value changes.

              Regards,

              Ferdinand

              Comment


              • #8
                Don't works.

                My cmdline.txt :

                dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
                4dpi.rotate=90 4dpi.pwm=0

                After reboot, nothing happens. Tried to erase the 4dpi.pwm=0 just in case, but it is the same.

                The file "/sys/module/4dpi/parameters/rotate" always contains the same value, 180

                I will try to start with a new raspbian image just in case I modified anything and I will tell.

                Thanks

                EDIT : When I saved this post, I realized there was a CRLF in the cmdline.txt. I erased it and now it is as follows

                dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait 4dpi.rotate=90 4dpi.pwm=0

                With this change, what I get now in the file "/sys/module/4dpi/parameters/rotate" it is 270, by setting 4dpi.rotate=0 I get 180, by setting 4dpi.rotate=180 I get the right rotation

                Thanks :D
                Last edited by Colomer; 29 July 2016, 03:39 PM.

                Comment

                Working...
                X