Announcement

Collapse
No announcement yet.

4DPi-24-HAT X Server - No Screens Found

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4DPi-24-HAT X Server - No Screens Found

    I booted a fresh install of the latest version of Jessie with Pixel. I followed the steps in the datasheet to install the 4d kernel "4d-hats_4-4-21_v1.0.tar.gz". If I boot to CLI, the screen works fine, although I can't launch X Server. I am using the Rapberry Pi 3.



    Here is the contents of Xorg.0.log
    [ 10.777]
    X.Org X Server 1.18.4
    Release Date: 2016-07-19
    [ 10.777] X Protocol Version 11, Revision 0
    [ 10.777] Build Operating System: Linux 4.4.26-v7+ armv7l Raspbian
    [ 10.777] Current Operating System: Linux raspberrypi 4.4.21-v7+ #3 SMP Tue Oct 18 12:23:35 CEST 2016 armv7l
    [ 10.777] Kernel command line: 8250.nr_uarts=0 dma.dmachans=0x7f35 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=1080 bcm2709.boardrev=0xa02082 bcm2709.serial=0xb2d34824 smsc95xx.macaddr=B8:27:EB:D3:48:24 bcm2708_fb.fbswap=1 bcm2709.uart_clock=48000000 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000 dwc_otg.lpm_enable=0 console=ttyS0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
    [ 10.777] Build Date: 11 November 2016 11:59:59AM
    [ 10.777] xorg-server 2:1.18.4-2+rpi1 (https://www.debian.org/support)
    [ 10.777] Current version of pixman: 0.33.3
    [ 10.777] Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    [ 10.777] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 10.778] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec 20 04:23:12 2016
    [ 10.778] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [ 10.779] (==) ServerLayout "TFT"
    [ 10.779] (**) |-->Screen "ScreenTFT" (0)
    [ 10.779] (**) | |-->Monitor "MonitorTFT"
    [ 10.779] (**) | |-->Device "DeviceTFT"
    [ 10.779] (**) | |-->GPUDevice "DeviceTFT"
    [ 10.779] (==) Automatically adding devices
    [ 10.779] (==) Automatically enabling devices
    [ 10.779] (==) Automatically adding GPU devices
    [ 10.779] (==) Max clients allowed: 256, resource mask: 0x1fffff
    [ 10.779] (WW) The directory "/usr/share/fonts/X11/misc" does not exist.
    [ 10.779] Entry deleted from font path.
    [ 10.779] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    [ 10.779] Entry deleted from font path.
    [ 10.779] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    [ 10.779] Entry deleted from font path.
    [ 10.780] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    [ 10.780] Entry deleted from font path.
    [ 10.780] (==) FontPath set to:
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    built-ins
    [ 10.780] (==) ModulePath set to "/usr/lib/xorg/modules"
    [ 10.780] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
    [ 10.780] (II) Loader magic: 0x54d43f20
    [ 10.780] (II) Module ABI versions:
    [ 10.780] X.Org ANSI C Emulation: 0.4
    [ 10.780] X.Org Video Driver: 20.0
    [ 10.780] X.Org XInput driver : 22.1
    [ 10.780] X.Org Server Extension : 9.0
    [ 10.782] (++) using VT number 7

    [ 10.782] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
    [ 10.782] (II) no primary bus or device found
    [ 10.782] (II) LoadModule: "glx"
    [ 10.783] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [ 10.787] (II) Module glx: vendor="X.Org Foundation"
    [ 10.787] compiled for 1.18.4, module version = 1.0.0
    [ 10.787] ABI class: X.Org Server Extension, version 9.0
    [ 10.787] (==) AIGLX enabled
    [ 10.787] (==) Matched modesetting as autoconfigured driver 0
    [ 10.787] (==) Matched fbdev as autoconfigured driver 1
    [ 10.787] (==) Assigned the driver to the xf86ConfigLayout
    [ 10.787] (II) LoadModule: "modesetting"
    [ 10.787] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
    [ 10.788] (II) Module modesetting: vendor="X.Org Foundation"
    [ 10.788] compiled for 1.18.4, module version = 1.18.4
    [ 10.788] Module class: X.Org Video Driver
    [ 10.788] ABI class: X.Org Video Driver, version 20.0
    [ 10.788] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [ 10.788] (WW) Falling back to old probe method for modesetting
    [ 10.788] (EE) open /dev/dri/card0: No such file or directory
    [ 10.788] (EE) No devices detected.
    [ 10.788] (EE)
    Fatal server error:
    [ 10.788] (EE) no screens found(EE)
    [ 10.788] (EE)
    Please consult the The X.Org Foundation support
    at http://wiki.x.org
    for help.
    [ 10.788] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [ 10.788] (EE)
    [ 10.808] (EE) Server terminated with error (1). Closing log file.

  • #2
    Same issue with 4DPi-35 http://pastebin.com/REjJacyN

    Comment


    • #3
      I managed to fix my issue a couple of days ago, but I forgot to post it on here. I am not sure which of these solved it, but the two things I did was:
      1. Used Raspbian Jessie dated 2016-09-23
      2. Skipped the step suggesting to do sudo apt-get update and upgrade

      I hope this helps!

      Comment


      • #4
        Originally posted by JammyMoore View Post
        I managed to fix my issue a couple of days ago, but I forgot to post it on here. I am not sure which of these solved it, but the two things I did was:
        1. Used Raspbian Jessie dated 2016-09-23
        2. Skipped the step suggesting to do sudo apt-get update and upgrade

        I hope this helps!
        Yes it did ! I have managed to get it to work on the old Raspbian image. So something in the new kernel is not compatible with the drivers or something, this should with huge letters next to this display in each eshop, I was going to return mine as faulty after holidays... now its working, only issue is that the OS is old... I will make an image of current state so I can have fall back position and will try to update the environment without kernel, if it breaks.

        Comment


        • #5
          One more update from me today.
          I have disabled update of following packages:

          sudo apt-mark hold xserver-common xserver-xorg xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-video-fbdev xserver-xorg-video-fbturbo realvnc-vnc-server raspberrypi-kernel raspberrypi-bootloader

          The issue is either with kernel or xserver. Xserver received some serious update, it also warns about it during update that its not run under root and so on... so that might be the issue, but thats up to developers, hopefully they have a look at it.

          Comment

          Working...
          X