Announcement

Collapse
No announcement yet.

4DPi-35 - Can't get X to show

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4DPi-35 - Can't get X to show

    Hello,
    I have been trying whole day today to make the display work on mi Pi 3B and no luck.. well partial luck, I can get it to display this on and than it get stuck:

    https://www.youtube.com/watch?v=oQPexgjNacU

    As you can see it gets stuck, and sometimes bit sooner... I have no idea what is wrong with it ( I can ssh to it just fine )

    What I did:

    Installed fresh raspberian and updated it completely including FW for PI as 23.12.2016 then by followed this:

    INSTALLATION
    Download kernel sources

    From linux directory:
    cd drivers/video
    git clone https://bitbucket.org/4DPi/4d-hats.git

    Add to drivers/video/Kconfig: source "drivers/video/4d-hats/Kconfig"
    -----------------------------------
    config HDMI
    bool

    source "drivers/video/4d-hats/Kconfig"

    if VT
    source "drivers/video/console/Kconfig"
    endif
    -----------------------------------

    Add to drivers/video/Makefile: obj-y += 4d-hats/
    -----------------------------------
    obj-y += fbdev/
    obj-y += 4d-hats/

    obj-$(CONFIG_VIDEOMODE_HELPERS) += display_timing.o videomode.o

    -----------------------------------

    Enable driver(s) in menuconfig and build the kernel:
    Device Drivers-->Graphics support

    <*> Support for 4D Systems display modules --->
    <*> 4D Systems LCD HAT support (2.4, 3.2 and 3.5 inch)
    <*> DMA Enabled SPI Master Driver
    <M> Module for ADS7846 resistive touch screen controller

    <M> Module for AR1020 resistive touch screen controller
    <M> Module for DMA supported PWM backlight driver


    make -j4 zImage modules dtbs
    sudo make modules_install
    sudo cp arch/arm/boot/dts/*.dtb /boot/
    sudo cp arch/arm/boot/dts/overlays/*.dtb* /boot/overlays/
    sudo cp arch/arm/boot/dts/overlays/README /boot/overlays/
    sudo scripts/mkknlimg arch/arm/boot/zImage /boot/$KERNEL.img

    Compiling device tree overlays (only necessary if overlay sources are mofified):
    recent dtc (device tree compiler) has to be installed. A script is provided.
    For example DT overlay for 24-hat can be compiled with:

    ./dtc.sh 24-hat

    resulting .dtb files should be flashed to HAT EEPROMs or copied to:
    /boot/overlays on RPi.

    *I didn't do the part in red


    From the forum here I did additional steps:

    #Extract 4D-HAT driver files to local directory
    [email protected]:~ $ wget http://www.4dsystems.com.au/download...21_v1.0.tar.gz
    [email protected]:~ $ mkdir 4D
    [email protected]:~ $ tar -xzvf 4d-hats_4-4-21_v1.0.tar.gz -C 4D

    #copy setting file
    [email protected]:~ $ sudo cp 4D/usr/share/X11/xorg.conf.d/99-fbturbo.conf /usr/share/X11/xorg.conf.d/

    #edit "rc.local"
    [email protected]:~ $ sudo nano /etc/rc.local
    # Print the IP address
    _IP=$(hostname -I) || true
    if [ "$_IP" ]; then
    printf "My IP address is %s\n" "$_IP"
    fi

    con2fbmap 1 1

    exit 0

    #edit "modules"
    [email protected]:~ $ sudo nano /etc/modules
    i2c-dev
    #pwmbl
    ar1020-i2c
    #4dpi_touch

    In the end I have renamed the new Kernel7.img to kernel.img inside /boot to boot to the new kernel. Rebooted and result you can see up top :-/

    *Edit - The fresh install of respberian used to boot to the X/Pixel, when HDMI was connected. Just after adding the new kernel and display it get stuck :-/

    here is
    Xorg.0.log that shows some kind of error:

    http://pastebin.com/REjJacyN

    *Edit 2 - replacing everything using
    4d-hats_4-4-21_v1.0.tar.gz like:
    sudo tar -xzvf 4d-hats_4-4-21_v1.0.tar.gz -C /

    Will brick the Pi3, it will not boot up anymore - It blinks like it start booting but then shuts down immediately, putting backup image to the SD card will make it work again...
    Last edited by VladoPortos; 24th December 2016, 07:32 PM.

  • #2
    Hello,

    My raspberry pi works fine.
    The hardwares are both pi2B & pi3.

    The kernel version is same to yours(kernel-4.4.39)
    Settings is same to yours too.

    I built up the kernel with Pi2B.
    I have not tried in pi3 yet.

    My first kernel build was standard.(without 4D)
    I built in 4D-driver by the second build.

    I hope this helps you.

    Comment


    • #3
      Originally posted by eokayama View Post
      Hello,

      My raspberry pi works fine.
      The hardwares are both pi2B & pi3.

      The kernel version is same to yours(kernel-4.4.39)
      Settings is same to yours too.

      I built up the kernel with Pi2B.
      I have not tried in pi3 yet.

      My first kernel build was standard.(without 4D)
      I built in 4D-driver by the second build.

      I hope this helps you.
      Issue is with either new kernel or because of changes in xserver.

      I did a lot of experimentation to narrow it down but in the end what worked is to use older image of Rasbian from 2016-09-23 and block following packages from update:


      sudo apt-mark hold xserver-common xserver-xorg xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-video-fbdev xserver-xorg-video-fbturbo realvnc-vnc-server raspberrypi-kernel raspberrypi-bootloader

      Then it works ok, the moment you update xserver ( or kernel not sure about this one ) then it stop working, the X will not start on the display.

      Comment


      • #4
        Originally posted by VladoPortos View Post

        Issue is with either new kernel or because of changes in xserver.

        I did a lot of experimentation to narrow it down but in the end what worked is to use older image of Rasbian from 2016-09-23 and block following packages from update:


        sudo apt-mark hold xserver-common xserver-xorg xserver-xorg-core xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-video-fbdev xserver-xorg-video-fbturbo realvnc-vnc-server raspberrypi-kernel raspberrypi-bootloader

        Then it works ok, the moment you update xserver ( or kernel not sure about this one ) then it stop working, the X will not start on the display.
        I did not notice it.
        I did an additional experiment.
        You are right.

        Originally posted by VladoPortos View Post

        use older image of Rasbian from 2016-09-23 and block following packages from update:
        Rasbian image 2016-11-25-raspbian-jessie.img is also available.
        Last edited by eokayama; 27th December 2016, 08:11 PM.

        Comment

        Working...
        X