No announcement yet.

  • Filter
  • Time
  • Show
Clear All
new posts


    Hi everybody

    Error: Can't open include file 'C:\Users\Public\Documents\4D Labs\Diablo Designer\': No such file or directory (line 4 file:NoName1.4dg)
    Where can I find this file Thanks in advance Atal

  • #2
    Hi Toni1959,

    What is the filename of that project?
    Is the a filename or previous project that hasn't been deleted or has been copied? Can you try deleting that line?

    The inherit file for using the keybard is..#inherit ""

    Your project may also automatically includes the #inherit ""

    Have you tried the example keyboard projects in 'Sample' - 'Picaso Visi' - ex: 'KEYBOARD '

    This might be a related post:
    Error: Can't open onclude file ``: No such file or directory



    • #3
      Hi Joseph,
      Workshop I use Pro Trials To use a keyboard can be a Pro license ned? Thanks in advance greetings Antal


      • #4
        Hi Toni,

        The Keyboard widget can still be used from the widgets panel without a license. It is included in the free Workshop 4 software.

        The workshop pro unlocks the Magic tab (Magic Event, Magic Touch, Magic Code, etc..) that allows the insertion of 4DGL code in various points in Visi-Genie..

        You can still use the keyboard unless you are using the Magic to control them, that needs the License or you can use the Visi Environment.

        Here are some App notes that might be helpful:

        ViSi-Genie Customised Keyboard

        Visi-Genie Password Implementation with an Arduino Host

        ViSi-Genie Inputs

        ViSi-Genie Magic Keyboard Edit

        From your previous post, you might find the include files here: C:\Program Files (x86)\4D Labs\4D Workshop 4 IDE\INCLUDE



        • #5
          Hi Joseph

          this is my projects

          Unfortunately, the keyboard does not want to work with all time

          please if you can send a sample program
          Thanks in advance Greetings Antal


          • #6
            Hi Toni,

            What seems to be the problem is in the video and what Workshop 4 environment did you use?

            Here are some sample projects using the keyboard:

            For Visi-Genie environment:
            Visi-Genie Password Implementation with an Arduino Host

            For Visi environment:
            Workshop 4 - 'File' - 'Samples' - Picaso Visi' - 'KEYBOARD'
            (also attached this one here)

            Attached Files


            • #7
              Hi Joseph

              Thanks for the reply but I have already solved the Keyboards.

              It was used in the film VISI GENIE

              Thanks for the example code.


              On the keyboard and the VISI, a keyboard that works well.

              Aanother question.

              If the touch screen for use it, in VISIS software Form1, Form2 ,Form3, Form4 ..

              Ower RS232 can swap the cards Form1 form2, Form3, Form4 ..

              Thanks in advance Greetings Antal


              • #8
                Hi Antal, thanks for the video..

                You can code your visi project to switch forms when it received an expected data through Serial / RS232.

                In switching multiple forms in Visi, this Application Note might help:

                ViSi Form Switch

                These kind of commands might be interesting, such as to show background images of a form, etc..

                For a Picaso/Diablo ViSi project:
                // Form2 1.0 generated
                img_Show(hndl,iForm2) ;

                For Serial Communication / RS-232, this forum post might help you:

                Serial Communication uLCD-32PT

                You can also check the example projects:
                Worshop - 'File' - 'Samples' - Picaso Designer' - Picaso - Serial Comms'

                Hope this helps,


                • #9
                  Hi Joseph
                  Thank you for answering
                  Now I have another urgent projects

                  Thanks in advance
                  Greetings Antal


                  • #10
                    This is my problem with 4D, when i start, it prints this error message,and the program will not start. I have downloaded the latest version
                    I haven't used the program for three years,now i wanted to work with it but it wan't start,please help me to continue working with the program.

                    Thanks in advance
                    Greetings Antal
                    Attached Files