No announcement yet.

µOLED 128 GMD1 freezes on first serial command

  • Filter
  • Time
  • Show
Clear All
new posts

  • µOLED 128 GMD1 freezes on first serial command

    Hi to all.
    Yesterday I found forgotten but loved4D uOLED display...Since this morning (now is 21:45 in my time zone) I was not able to make it work.

    - µOLED 128 GMD1 rev2 GOLDELOX - MD1 connected to the Arduino Mega2560(clone),
    - Hardware Serial used for communication

    From Display to Mega2560:
    Positive  to  5V
    Negative to  Gnd
    Rx via 1k resitor to Tx
    Tx to Rx
    - When Mega has been powered the uOLED is powerd too (start to scroll factory default text)
    - This display was used with success back in 2009 with Parallax SX28 & Propeller chips.

    - is always the same, after being powered (5 seconds delay in code) it starts to scroll from bottom up 4D SYTEM informations and after first command has received it freezes the display. here is the video :

    So far tried:
    - Converted code from SX28 and Propeller chip
    - Goldelox_Serial_4DLib
    - Plane serial commands refered to
    - Bunch other libraries
    - Hardware and Software serial
    - Jumper across two pins on the displays back, to play movie from micro sd card gives result, it plays video without the problem.

    Unfortunately don't have SX or Propeller to test it with code it works earlier.
    Any idea what else can be tried?

    Thank you!!!

    EDIT: instead of ACK byte it returns 0
    Last edited by Coyote; 27 February 2017, 06:44 AM.

  • #2
    there may have been a few IDE upgrades along the way, can you roll back arduino to an older version to see if the next compile makes it work again?
    I say this because I posted a link to another library for a user on the forum for goldelox and it worked for him, but i am curious to know if it's an IDE update or the new GCC causing this issue.
    i dont really consider changing library because your code was already written for your library, the other user was starting from scratch with the issue.

    Check out's archives and try an older version of the IDE, try to pick one closest to the year you had yours working and post back the results

    you may also post your code here in case somethings wrong if you changes anything since then, otherwise if nothing was changed and you just uploaded the same sketch, i would try the IDE with an older gcc to see if we go somewhere


    • #3
      Tony, thank you for your prompt reply.
      This display I was never used with Arduino before , it was used with Sx28 and Propeller mcu but I'm sure that problem with arduino can be IDE version.
      Tomorrow I'll try to roll back IDE to older version, since I never before used arduino with uOled 128 can you suggest some version of IDE that you know it should work?
      Thank you


      • #4
        I would try the 1.5.6+ or 1.6.5 IDEs

        if your still having issues you may try an alternate library working on latest IDE can be found here:

        superhb confirmed it working

        but it would be good to know if the IDE gcc compiler was the issue causing the original library to fail, i've seen updates break things before,
        Last edited by tonton81; 27 February 2017, 07:30 AM.


        • #5
          The serial protocol for the very old GMD1 display is completely different to the current serial protocol, which the Arduino is using. (GMD1 serial became SGC serial, which became SPE serial)

          So, at a pinch the two devices are 'incompatible'.

          You *MIGHT* be able to put a UOLED-128-G1 Pmmc into it and load SPE, so that you can use it in this way, but we don't know, as we haven't been able to find one to try.