Announcement

Collapse
No announcement yet.

SSH very slow

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • majenko
    replied
    This is a known and documented issue. Broadcom were contacted for a resolution, and their response wasn't that great to be honest.

    There's details on Unix.StackExchange.com about it:

    * http://unix.stackexchange.com/questi...address-issues

    To get round the problem I wrote a small program that groks the firmware file and changes the MAC address within it. Not perfect, but it worked at the time. There's a link to the github repo in the page above.

    Leave a comment:


  • atzcapilla
    replied
    Hi, I was struggling with a similar issue and I just figured out that I had a MAC Address conflict.

    Let me explain:

    I was generating microSD cards from the same .img master image and then using more than one device at a time at the SAME NETWORK.

    To my surprise, all the Armadillo boards where using the same MAC Address, and therefore I was having many network problems (many lost packages in pings, ssh problems and delays, etc.)

    Therefore, I suggest to check if the MAC Address of your Armadillo boards are different.

    By the way, I could'nt find out a 'nice' way of configuring the IP / MAC address to be permanent and reset proof.

    Hope this will give clues to some users.

    Leave a comment:


  • jamespaulpena
    replied
    Redirected to this forum thread

    Leave a comment:


  • davemmclaughlin
    replied
    Hi James, for reference in case anyone else has the same issues, I discovered that the issue is related to using wired Ethernet and still having WiFi enable but not connected. Once I disabled WiFi it works perfectly over the wired Ethernet connection.

    What I can't seem to do right now is see how to permanently disable the WiFi as each time I reboot it is active and scanning. I want to be able to disable this permanently as I will be using wired only with these units and don't want the issue above to appear.

    Leave a comment:


  • James_4DSystems
    replied
    Sure, mine is fast in both respects. Type and its instantly showing on Putty, and press enter at the end of the command and its processed immediately. No lag in any sense.
    I have never seen it lag at all, ever, in the last 2 or so years we have been producing these.
    I am not sure what to suggest sorry.
    You tried a different PC or network?
    We have used Armadillo's in 4 of our worldwide offices, and never experienced this. You are the first customer to raise this too I believe. Wondering if its somehow related to your setup, and not the Armadillo... Really dont know.

    Leave a comment:


  • davemmclaughlin
    replied
    The delay is not in the command being processed, it is in SSH responding to input. If I type LS for example, it can take anything from 5 second to minutes before this appears and executes.

    This happens over WiFi or Ethernet

    Leave a comment:


  • James_4DSystems
    replied
    Hi Dave

    I have just taken a Armadillo-70T, one of our 4GB Industrial SD cards, written on the Jessie 1.4 image, plugged in Ethernet cable, and booted it up.
    Set up Armadillo Ethernet to DHCP using Armadillo-config, rebooted, and SSH'ed using Putty from my PC into the Armadillo

    It runs perfectly fast...

    No delay at all....

    Click image for larger version

Name:	2017-03-04_0-34-12.png
Views:	1067
Size:	27.0 KB
ID:	56380

    Leave a comment:


  • davemmclaughlin
    replied
    This is so damn frustrating to try and do any work on these with SSH as slow as it is. I need to copy and paste commands from a document to setup the boards so I can't work directly on them with a keyboard.

    I wish there was a working solution for this.

    Even mobaXTerm is very very slow.

    Leave a comment:


  • Joseph Herrera
    commented on 's reply
    Hi dave,

    Thanks for the info.
    It seems some raspberry pi users in these forum threads are also experiencing issues with their sd cards. Some used extra ram partions to make it faster.

    Raspberry Pi SSH login slow
    http://raspberrypi.stackexchange.com...ssh-login-slow

    Experiencing slow response with Raspbian 2012-09-18
    https://www.raspberrypi.org/forums/v...19379&p=225819

  • davemmclaughlin
    replied
    I have just created a new image and put this onto a 64GB class 10 card and SSH is now good. Put back the 4GB industrial one I got with the unit and SSH is slow again. Strange.

    I'll check out mobaXTerm.

    Leave a comment:


  • Joseph Herrera
    replied
    Hi dave,

    Have you tried it on another network? Or use another ssh terminal like mobaXTerm?

    Some raspberry pi users seemed to have encountered this problem and some of their issues were ssh settings.

    Maybe these links might help:

    Raspberry Pi SSH Lag
    http://superuser.com/questions/82099...rry-pi-ssh-lag

    SSH is slow as hell
    https://discourse.osmc.tv/t/solved-s...w-as-hell/3813

    Raspbian slow SSH fix
    http://www.coreforge.com/blog/2014/0...-slow-ssh-fix/

    Hope this helps,

    Leave a comment:


  • davemmclaughlin
    replied
    I've now tried Putty and it is extremely slow on SSH. If I open a terminal on the device itself and use a USB keyboard all is fine. SSH via the network connection is painfully slow. I typed in LS after first opening the connection and it took 2 seconds to show. The second time it took around 15 seconds and the 3rd command took almost 2 mins. Each subsequent command takes long than the next.

    Something is very wrong.

    Strangely enough, debugging over the network connection from Visual Studio is fine and no issues.

    Leave a comment:


  • davemmclaughlin
    started a topic SSH very slow

    SSH very slow

    When I SSH into the Armadillo-70T and type, it takes anything from 5 to 30 seconds for the command to appear on the terminal. It does this over WiFi or Ethernet connection.

    Is this normal? I certainly don't get this with any Raspberry Pi.

    It makes developing quite tedious and very slow.
Working...
X