No announcement yet.

uSD mounting problem with uLCD-43DT

  • Filter
  • Time
  • Show
Clear All
new posts

  • uSD mounting problem with uLCD-43DT

    Good Momornig.. i've a problem with uLCD-43DT. i bought some uSD industrial Grade 512MB for my application , but at boot uLCD don't mount succesfully the disk ant continue to print "Drive not mounted..." in the loop created by Visi . If , during this loop i extract and reinsert the uSD , file_Mount() complete succesfully and work fine..
    I try several uSD into several uLCD-43DT with same result
    try to reformatting uSD with same result
    try to put a pause before file_Mount() with same result
    try to increas pause into the loop (normally 200ms) with same result
    try with other uSD 4GB non industrial Grade (generic one) and work fine

    Some info: PmmC r20
    Attached uSD Datasheet.
    Any suggestion for me?
    thanks in advance
    Attached Files

  • #2
    I'm surprised you are having those issues, but I am not sure if you could get past them that you would have any success.

    A large user previously told us that he tested Industrial cards from this vendor and found them to be significantly slower than other brands. I presume this is because we use SPI mode, whereas their datasheet quotes their speeds in SD mode, which is fully understandable.


    • #3
      thanks for answer.. in your opinion there are any workarounds that permit to use these uSD, i bought more than 20 pcs and they are much expensive..


      • #4
        I'll send you a PM