Announcement

Collapse
No announcement yet.

Newe Pi Zero W kills 4DPi-24-HAT

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Newe Pi Zero W kills 4DPi-24-HAT

    Hello

    I have tried twice, but did not succed : my previous Pi Zero motherboard (1.3) worked flawessly with the 4DPi 24 HAT.
    After receiving the newest Pi Zero W moterboards, with embedded WiFi and Bluetooth, plugging the 4DPi 24 HAT "kills" the screen, which only displays a blank screen ...
    The Pi is still working though, i can access it remotely.

    My father also did the same and had the same issue.

    Are we the only ones whith this problem ?
    Is the problem known by 4D ? And is someone adressing it ?

    Thank you
    Laurent

  • #2
    Hello Laurent

    The 4DPi-24-HAT I dont believe has been confirmed to be working with the Pi Zero board, it is not documented as being compatible anyway.
    However that said, if the Pi Zero runs the same Raspbian release as the normal Pi's, then it should be OK.
    You have confirmed it working on REV 1.3 of the Pi Zero, correct?
    What is the revision of the new ones you have?
    Have you compared their schematics to see if anything changed in that regard?

    When you say it 'kills' the screen, can you give more information as to what actually happens, tell us error messages or logs, and show screenshots or video of the problem?

    This is the first we have heard of it, but that said, we have never stated compatibility for the Pi Zero. We will do our best to support you though, but please provide more information.

    Regards
    James

    Comment


    • #3
      Sorry Laurent,

      Ignore some of what I wrote.

      We do have a release which is ready for release which supports the Pi Zero's new WiFi version.
      Please link to this 4DPi release, and see if this works for you.

      Code:
      http://www.4dsystems.com.au/downloads/4DPi/All/4d-hats_4-4-50_v1.0.tar.gz
      http://www.4dsystems.com.au/download...50_v1.0.tar.gz

      Kind Regards
      James

      Comment


      • #4
        Hello James

        Unfortunately it does not work. Your screen used to work perfectly on my Pi Zero 1.3

        But now on the Pi Zero W, with the new packet installed on top of my Rasbian distribution, I get a white bright screen.
        It looks as if the luminosity is turned to the maximum ...
        The Pi works underneath, as i can access it with ssh.

        What I did was the following :

        sudo wget http://www.4dsystems.com.au/download...50_v1.0.tar.gz
        sudo tar -xzvf 4d-hats_4-4-50_v1.0.tar.gz -C /
        sudo halt

        Power unplug

        Install the screen

        Plug in the power

        The screen is full bright white as in the picture attached ...

        When i reboot, or when the screen and Pi go into power save mode, i got the same bright white screen back again when it restarts


        Fyi, I use the following Rasbian distribution : 2017-03-02-raspbian-jessie.img


        Can you test also on your side, and post for us to download, a working image of a Rasbian distribution with your drivers for ths screen ??

        Thank you in advance
        Laurent

        Click image for larger version  Name:	IMG_6961.JPG Views:	2 Size:	3.26 MB ID:	56952
        Attached Files
        Last edited by lheride; 29 March 2017, 07:23 AM.

        Comment


        • #5
          Hi Laurent

          Sorry you are having problems.
          White screen just means the backlight is on and its displaying no content. So it seems it either doesn't know the screen is connected, or there is something else wrong.

          I already have on order a Pi Zero W, but world supply is pretty short so its coming from Europe, so please bare with us. Our software developer may come back with a solution before it arrives however.

          Just out of interest, have you tried forcing the 4DPi-24-HAT to load in the config.txt file, by un-commenting the #dtoverlay=24-hat line? Instead of letting it determine it by EEPROM? This may not do anything at all, but give it a try. Our developer will reply as soon as they are able.

          I assume you are running the latest from the Pi site? https://www.raspberrypi.org/downloads/raspbian/

          Regards
          James

          Comment


          • #6
            Hi Laurent,

            I have just tested the 4.4.50+ kernel package + Raspbian 2017-03-02 with Pi Zero W, and it works fine. The image also works with the non W Pi Zero.

            Please check if your image works with Pi Zero, but not with Pi Zero W. If that is the case, image is OK, and maybe check if 40-pin header is properly soldered on the Zero W...

            Regards,
            Andrej

            Comment


            • #7
              Hi James, Andrej and Laurent !


              I am desappointed to have always the same behavior
              - Using both pi0w and pi3 ( pin are soldered bu factury )
              - using two 4DPI
              - Using raspbian 2017-03-02
              - Using 4.4.50 patch

              I made OS Rasp.img wihout any problem because each raspberry works using command mode

              Questions are :
              have You different release for the firmware and how i chek i use the last one

              Can You give access ( download) to the raspbian you use ?

              Tks a lot for your answare

              Arnaud

              Comment


              • #8
                Juste to add, the 2 raspberry run without trouble with sense hat and automation hat !
                BR
                Arnaud

                Comment


                • #9
                  Hi,

                  tested installing from scratch again, and it worked. Here is what I did:

                  - flashed a 2017-03-02 Raspbian Jessie image to a SD card
                  - logged to P- Zero-W as pi/rasperry

                  wget http://www.4dsystems.com.au/download...50_v1.0.tar.gz
                  sudo tar -xzvf 4d-hats_4-4-50_v1.0.tar.gz -C /
                  sync
                  sudo reboot

                  wait for sync to finish, it prevents disconnecting power to soon, before everything has been written to SD card

                  Best regards,
                  Andrej

                  Comment


                  • #10
                    Hello

                    I have ordered a new screen in order to be sure that there is no hardware malfunction on the screen part.
                    Here is the screen i have ordered :
                    https://fr.farnell.com/webapp/wcs/st...2Fdp%2F2456984

                    Maybe there is a firmware issue ?

                    I will test on a __brand new Pi 3__ hardware to be sure that no soldering problem happens.
                    Then i will test again on the Pi Zero W.


                    On my current configuration (Pi Zero W and touchscreen which stays bright blank), i can change the luminosity using brightness parameters, but the icons and the desktop never appears.
                    Other screens that i attach to the Pi Zero W (sense hat) work flawlessly ...

                    I dont understand what is wrong ....

                    If someone can upload somewhere a full working image for me to download, that would be very helpful ....

                    thank you in advance
                    Laurent

                    Comment


                    • #11
                      Hello
                      To add more information to the post from Laurent :
                      I am surprise I not find information into the file /boot/cmdline.txt about 4DPI as you have given in your
                      4DPi-24-HAT_datasheet

                      no parameter: 4dpi.rotate = 0 for exemple

                      [email protected]:/boot $ cat cmdline.txt
                      dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadlin
                      e fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
                      [email protected]:/boot $


                      Is it for you a normal behavior ?

                      BR
                      Arnaud

                      Comment


                      • #12
                        It works - perfect !!
                        I have received the new screens and it now works flawlessly with the Pi 3 and the Pizero W.

                        So it must have been some hardware malfunction. It happens ... that s life ....


                        --> James, i will send you a PM as i have a specific demand.


                        Best regards and thank you all for your help

                        Comment

                        Working...
                        X