Announcement

Collapse
No announcement yet.

Strange behaviour

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange behaviour

    Hi !

    I have a problem with 4DPi-24-HAT and hope to find some help.

    First, I followed the datasheet http://www.4dsystems.com.au/productp...heet_R_1_9.pdf and it was working fine with my raspi 3.
    Then the touch feature wasn't responding at all.

    I tried by putting a new image and follow again the tuto but it went wrong and nothing could be shown on the touch screen.
    I tried again without the apt-get update and upgrade, the touch screen was working except for the touch feature.

    What could be the problem, sd card, 4DPi-24-HAT kernel version ?

    ps : with a pi 2 the 4DPi-24-HAT worked perfectely fine so it's really strange.

  • #2
    userThomas,

    The latest raspberry Pi image with the 4D-PI-24-HAT package
    already applied can be found with this link:

    https://www.dropbox.com/s/ok1wn9a1o7...rryPi.img?dl=0

    Just use win32diskimager to load the image to a uSD card and insert
    the USD card to the Raspbery Pi and it will work without changing anything.

    It uses the 4D PiHAT package 4d-hats_4-4-34_V1.1.tar.gz since
    the 4d-hats_4-4-50_V1.0 has a bug in the calibration of the screen.


    Please check your power supply for the raspberry Pi if the output
    current is equal or greater than 1 ampere or it will fail to boot.

    Best regards,

    Comment


    • #3
      I just got a 4DPi-24-HAT, followed the instructions on your website (same as userThomas linked) and after connecting the screen and plugging in the pi I got nothing. The screen remained black. Before installing your patch it displays everything over hdmi on a monitor just fine. I tried the whole process again with an apt-get update/upgrade before wgetting your patch and still nothing at all on the screen. I used the image from your dropbox link above and the screen works fine. I think the 4-4-50 patch has more than just a calibration issue, because I never got that far.
      Raspbian 2017-04-10. My power supply is new from the pi3 kit, 5.25v 2500ma.

      Comment

      Working...
      X