No announcement yet.

Can't get sync working (uCam-III with uCam-II library)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get sync working (uCam-III with uCam-II library)

    I've been trying to get the uCamIII working by using this library:
    I'm working on an Arduino HUZZAH ESP8622.

    As of now the syncing wont work, I've tried different baudrates, but the one which seems to work the best is 56000. I've initizlied it as a softwareserial, on 13 and 15 (RX AND TX), but the data sent back from the camera seems to be random (?)

    Here is a snippet of the feedback from the camera:

    WAIT: 0xAA 0xE 0xD 0x0 0x0 0x0
    GOT : 0xE 0x1D 0x0 0x0 0x0

    Sending SYNC...

    WAIT: 0xAA 0xE 0xD 0x0 0x0 0x0
    GOT :

    Sending SYNC...

    WAIT: 0xAA 0xE 0xD 0x0 0x0 0x0
    GOT : 0xAA 0xD 0x0 0xD 0x0 0x0

    Very often the "GOT: XX XX XX" is of the form "0xE 0x.." something, and it seems to be counting upwards.

    I've also tried resetting the camera by both writing the reset command and by trying to use the reset pin, and this seems to be working. I use the LED light to see this visually.


  • #2
    Hello Coucheron,

    Have you tried to use the uCAM on the hardware serial port by disconnecting the programmer and attaching the camera using this hadware serial port. Software Serial is not known to be that reliable on the ESP8266, wheras the hardware serial boast's large fifo buffers and works extremely well.

    I hope this helps

    Best regards



    • coucheron
      coucheron commented
      Editing a comment
      Thanks for the help!

      Solution: I used Serial.swap, and I now get both output from printing and the camera is working. Continued to use the RX TX on the ESP8622, but since I now swapped the USB will use the other RX/TX on the Adafruit Huzzah ESP8622 :-)

      Best regards,