Announcement

Collapse
No announcement yet.

4dpi-32-II screen/font/window size

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4dpi-32-II screen/font/window size

    Hi all,
    Pi 3 B with Rasbian kernel 4.9.35-v7+.

    System boots to 32 screen ok however the displayed icons, fonts and window decoration appear too large and it is impossible to reach (see) OK buttons etc with the mouse.

    Can someone please tell me how to set the display size so that normal GUI navigation can take place?

    Best regards,
    ozpoz

  • #2
    Hello,

    Welcome to the forum,

    This is more of a workaround on how to resize icons to avoid overlapping so you can have more access on the Taskbar.

    Go to Preferences > Apperance Settings. (or right click and select Desktop Preferences)

    On Menu bar > Size - select Small

    Right click on Taskbar and click on Panel Settings > Geometry - reduce Icon size to 16 pixels.

    Right click on the icon and select Application Launch Bar Settings - Remove unwanted icons (i.e Mathematica, Wolfram etc)

    To resize desktop icons, open File Manager > Click on Edit > Preference > Display - Change size of icons (i.e large 20x20, small 12x12)

    Hope this helps.

    Best regards

    Paul

    Comment


    • ozpoz
      ozpoz commented
      Editing a comment
      Hi Paul, Thankyou for the welcome and suggestion.
      Unfortunately I cannot access the ok button because it is off screen and not rendered.
      ozpoz

  • #3
    Hi Paul, Thankyou for the welcome and suggestion.
    Unfortunately I cannot access the ok button because it is off screen and not rendered.
    ozpoz

    Comment


    • #4
      Hello ozpoz,
      Try ALT+Left click combination to push the window off the top of the screen.

      Comment


      • #5
        Hi any 4D staff,
        These work arounds do not work. I am at the stage of returning this display having spent days getting it to boot and now I am unable display the gui in a usable fashon.

        I have a 7" display that works flawlessly. Is this ever going to work as it should ?

        Regards,
        ozpoz

        Comment


        • #6
          Hello Ozpoz,

          I apologise for the delay in getting a solution to you. Can you please bear with us a little longer while we indenify your issue and give you a workable solution.

          Best regards

          Paul

          Comment


          • #7
            Dear Ozpoz,

            This is the proper procedure to rezise your desktop.

            Procedure would be:
            Switch to HDMI,
            Adjust resolution related things,
            Switch back to 4dpi.
            GUI is trimmed for way higher resolution.

            Best Regards

            Paul

            Comment


            • #8
              Hi Paul,
              Thank you for responding.

              I am sorry but could you be a little more specific with OS/kernel/driver versions?

              The pi3 will not boot with 2017-07-05-rasbbian-jessie.img and 4d-hats_4-4-50_v1.0.tar.gz as per your documentation.

              I have been able get the pi to boot if I use the same OS and 4d-hats_4-4-34_v1.1.tar.gz but in raspi-config there is not a setting for 480 x 320 resolution and the resulting GUI is still unusable.

              Best regards,
              ozpoz

              Comment


              • #9
                Hi Ozpos,

                The latest version of Jessie.

                And this kernel for the Pi HAT

                http://www.4dsystems.com.au/download...35_v1.0.tar.gz

                To download and install files, enter the following commands in terminal/shell /SSH to download the kernel from the 4D Systems Server:

                $ wget http://www.4dsystems.com.au/download...35_v1.0.tar.gz
                $ sudo tar -xzvf 4d-hats_4-9-35_v1.0.tar.gz -C /

                Can I ask what position the jumper is on the back of the screen, If it is set to PWM or DMA change it to ON/OFF. and then try the OS/kernel/driver above.

                I hope this helps.

                Best regards

                Paul

                Comment


                • #10
                  Hi Paul, Thank you for responding.

                  The jumper is in the on/off position.

                  I followed your description and have just the same result (the TFT display is active but wrong resolution). There is not a display resolution setting in sudo raspi-config for 480 x 320. Unfortunately it is still unusable at 640 x 480.

                  Since the display shows text and responds to touch (although I have not calibrated) then presumably the hardware is OK.

                  Any ideas ?

                  ozpoz

                  Comment


                  • #11
                    Hi Ozpoz,

                    Are you able to boot to a HDMI screen and then resize the desktop whilst viewing the desktop on a HDMI device.

                    Beat regards

                    Paul

                    Comment


                    • #12
                      Hi Paul,
                      Just re-flashed the sd card for the 5th time. Are you suggesting there is a step before applying the kernel driver?
                      ozpoz

                      Comment


                      • #13
                        Booted to HDMI. Now what ?

                        Comment


                        • #14
                          Hi Ozpoz

                          Now you are in HDMI you will have to change your screen resolution settings if you can find a suitable resolution.

                          Goto preferences/ raspberry pi configuration and then click on set resolution, but I have noticed a problem on mine on hdmi, the lowest I get is 640x480. I hope yours is not the same

                          Paul

                          Comment


                          • #15
                            Hi Paul,
                            The lowest resolution is 640x480 which is no good.
                            Also the kernel 4d-hats_4-4-50_v1.0 that your latest docs refer to has never worked for me.
                            ozpoz

                            Comment


                            • James_4DSystems
                              James_4DSystems commented
                              Editing a comment
                              The docs will be updated asap. The kernel pack we offer needs to match the kernel being used by Raspbian. They change things so often is very hard to stay 100% in line with them. The latest kernel pack should update the latest raspbian build though, so all should be OK. Some issues can occur when you have a newer base raspbian and install an older kernel back, so the kernel ends up being downgraded, and some features/functions are then missing, and maybe some modules cannot load from the base image anymore, due to kernel mismatch etc.
                              Just some background info.
                          Working...
                          X