Announcement

Collapse
No announcement yet.

Help! GEN4-4DCAPE-70CT-CLB doesn't work with my BBB now

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help! GEN4-4DCAPE-70CT-CLB doesn't work with my BBB now

    I bought an old 4DCAPE-70T previously to run with BBB (Ubuntu version 13.08).
    It works fine.
    All I need to do is to use putty to log into BBB and issue the following commands at root:

    [email protected]:~# export DISPLAY=:0.0
    [email protected]:~# pcmanfm

    and I will be able to see the PCMan file manager running on the old 4DCAPE display beautifully.

    However, when I connect my BBB to the new GEN4-4DCAPE-70CT and issue the same commands via putty, I get this:

    [email protected]:~# export DISPLAY=:0.0
    [email protected]:~# pcmanfm
    Cannot open display:

    Suddenly pcmanfm would not work anymore. It says "Cannot open display" even though I have "exported" the DISPLAY.
    Do I need to load in a new driver for the new GEN4-4DCAPE-70CT to work with pcmanfm app?

    What is going on?

    (Note: in both the old and new 4DCAPEs, I use a 5V external power source to drive BBB rather than depending on the power coming from the USB connection between PC and BBB)



  • #2
    Hi Richard

    I suspect the problem you have is loading the old image onto the gen4-4DCAPE...
    The gen4-4DCAPE has different touch controllers, and backlight controllers, which have their own drivers, which were not included in the BBB release OS until recently.

    What OS version are you running?

    Can I suggest you try this one, which is what we tried running a few days ago and all seemed OK.

    https://rcn-ee.net/rootfs/bb.org/tes...-01-4gb.img.xz

    I believe the official latest-images page on the beaglebone.org site will be updated very shortly with a newer version, the version currently on there is from March.

    Does this help?

    Regards
    James

    Comment


    • #3
      Thank you James, for your reply.

      Currently, as said, we are using Ubuntu version 13.08. We are NOT using Debian Linux.
      We would like to keep our current Ubuntu Linux version as we have loaded quite a bit of other Linux stuff into the O/S.

      Do you have the drivers to your new gen4-4DCAPE?
      We will try to load it into our Ubuntu Linux.

      Thanks!

      Richard

      Comment


      • #4
        Hi Richard

        Sorry for the delay in response.

        I have never used Ubuntu, and I am waiting on a response from our developer on your question. But maybe the attached may help.
        Its the overlays for the various gen4-4DCAPE's, along with the driver for the Resistive Touch controller - however it appears you are using Capacitive touch so this will be N/A for you.
        I would hope the Kernel you are using is of similar era to the Debian official app, as drivers for Capacitive Touch are already in there.

        If you are still having problems, please reply, and hopefully our developer can get back to you with something more concrete.

        Regards
        Attached Files
        James

        Comment


        • #5
          Will wait for your developer's response. Basically, we just don't want to use another O/S as we have installed many other stuffs into our Ubuntu O/S. Thank you.

          Comment


          • #6
            OK just so this thread has all the information he may need, your are running Ubuntu 13.08 on the BBB, and what Kernel version do you have running?
            Can you provide the URL to the image you have used, or any other relevant information.

            Regards
            James

            Comment


            • #7
              Hi James,

              Thank you for your quick response. The followings are some of the information with regard to the Ubuntu O/S running on our BBB:

              3.8.13-bone30
              kernel version 3
              kernel major version 8
              kernel minor version 13

              DISTRIB_ID=Ubuntu
              DISTRIB_RELEASE=13.10
              DISTRIB_CODENAME=saucy
              DISTRIB_DESCRIPTION="Ubuntu 13.10"

              linux-firmware version 1.116 - Firmware for Linux kernel drivers
              linux-libc-dev:armhf version 3.11.0-20.34 - Linux Kernel Headers for development

              > uname -a
              Linux arm 3.8.13-bone30 #1 SMP Thu Nov 14 06:23:24 UTC 2013 armv7l armv7l armv7l GNU/Linux

              Comment

              Working...
              X