Announcement

Collapse
No announcement yet.

Disable LED Digits

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Disable LED Digits

    Hello,

    I am looking to disable the LED digits on my screen. I saw in another forum that it was possible to disable other objects with a -1, but this does not work for the LED digits. Anyone have any idea how to disable/re-enable them?

    Thanks!

  • #2
    Hello,

    Welcome to the forum.

    I don't think it is possible to disable an LED digit. Usually buttons can be disabled with -1 so long as this has been set in the Project tab to allow buttons to be disabled. One workaround would be to create another form without the LED digit and switch to that form when you don't require the LED digit.

    I hope this helps

    Best regards

    Paul

    Comment


    • #3
      Thank you for your answer Paul. Could explain what you mean by form?

      Comment


      • #4
        Hello,

        A form is like a page or screen that contains many widgets like buttons, gauges and Leddigits etc. You can have many forms in your project and switch between them for different functions.

        Initially, you start with Form0. You can add additional forms by simply clicking on Form0 on the Object Inspector and pressing Ctrl & C and then Ctrl & V. Form1 will then be shown as a blank form allowing you to add more widgets.

        I hope this helps.

        Best regards

        Paul

        Comment


        • #5
          WONDERFUL! That helps a lot. Thanks a bunch!

          Comment


          • #6
            in visigenie, writing 0xFFFF to leddigits widget should hide the leddigits object from the form page and bring it back when you write any other number to it, you must enable that option in the last tab of the IDE

            Comment


            • sbeube02
              sbeube02 commented
              Editing a comment
              Just tried and it does not work.

          • #7
            did you enable the checkmark in the workshop IDE software before writing to the screen?

            Click image for larger version

Name:	fetch?id=50861.png
Views:	19
Size:	161.4 KB
ID:	76817
            Last edited by tonton81; 15 September 2021, 03:40 AM.

            Comment


            • #8
              Yes it's allowed.
              The CustomDigit just displays "-1" when i send 0xFFFF. Please note that I also allowed negative numbers and leading blanks on Custom Digits.
              Maybe it only works for Led Digits?

              Comment


              • #9
                I'd imagine that would be the cause, as -1 is 0xFFFF so instead of disabling it treats it as the value, not sure

                Comment


                • #10
                  Hi,

                  Please note that I also allowed negative numbers and leading blanks on Custom Digits.
                  Enabling this enhancement can only turn your Ledgits and, Customdigits object to display negative values. One way you can dot to disable the Leddigits or the Customdigits is to cover it with a solid rectangle over the region of these objects.

                  If you are using the Workshop4 Pro, you can use a MagicCode to add the function gfx_RectangleFilled(x1, y1, x2, y2, color). Make sure that the background is a solid color and, the rectangle should match its color.

                  Another way you can do this is to add some form without Leddigits or Customdigits. You can switch between the forms to make if you want to enable/disable it.

                  Best Regards

                  Comment

                  Working...
                  X