Announcement

Collapse
No announcement yet.

RMPET not working in Windows 10?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RMPET not working in Windows 10?

    It looks to me like Windows 10 requires some sort of additional permission (besides being run as an administrator) to be granted for the raw access necessary to partition a sd card. Have you guys looked into this at all? I'm experiencing the same thing with a utility I built to automatically format my picaso sd cards.

  • #2
    As far as we are aware RMPET works exactly the same on Win10 as it did on previous versions.

    It is possible that your Antivirus product could be getting involved and stopping it working.

    Just what is it that appearing to not work?

    BTW, there is a hidden 'feature' that could possibly be causing issues and that is if Windows finds the remnants of an NTFS file system on a card it will not permit any writes beyond that sector regardless of admin status.
    Mark

    Comment


    • #3
      I don't have any antivirus running. When I try to delete the partition table I get a failure message.

      This action should just be writing to the very first sector of the card right? I have another program that also writes to the raw sectors of a drive and it gives me a similar error. The program is HxD.

      If you guys can use RMPET on Windows 10 then you're right, there must be something unique about my setup that's causing this.

      Click image for larger version

Name:	RPMET Fail.png
Views:	101
Size:	63.8 KB
ID:	60339


      Attached Files

      Comment


      • #4
        Err, yep, HxD is the program that I verified the 'Windows Feature' on.

        And if you want program that can write anywhere, and get rid of the NTFS artifacts, then WinHex can do that, but you will need the licensed version.

        Another thing that might work, although I haven't tried it, is to format using Windows and then copy a huge file to the drive. That will hopefully write over the sector that is causing the issue.
        Mark

        Comment


        • #5
          Yeah, as I pull out new cards they work, but reformatting something that's already been messed with get's denied... at least in Windows 10. Gotta figure out where I'm going wrong. Thanks for the help!

          Comment


          • #6
            Yuk, sounds like your cards are inadvertedly ending up with a sector containing what Windows thinks is an NTFS artifact.
            Mark

            Comment


            • #7
              Hi,
              I have just updated windows 10 and I am having the same problem that ipaq3115. Write failed with the RMPET. I have been using RMPET without problems until the last update. Which is the solution then ?
              Best regards

              Comment


              • #8
                I have found a possible solution for now. Making the format to FAT16 and creating a 4GB partition, following this link to step 9. https://vmspot.com/format-fat16-usb/ . Once done that the 4D workshop assumes the SD card has the right format and not ask to format using RMPET

                Comment


                • #9
                  There's a bit more to RMPET that that article might have missed

                  1. There should be an unused partition at the start of the card. RMPET leaves the first 8192 sectors unused. This is because the read disturb protection of industrial grade cards does not cover the entire card, so the start needs to be offset to ensure the partition is in the protected region of the card.
                  2. The maximum cluster size should be used. RMPET forces a 64kb cluster size, this gives the best performance. The default is the minimum possible size, this gives the best utilization of space, but the worst performance.
                  Mark

                  Comment


                  • #10
                    Hi Mark,
                    My problem is that RMPET is not working since my last windows 10 update. I do not want to create an alternative to RMPET, I have been forced to find it, since my customers are waiting.

                    The procedure I found is working, at least after that it allows to copy the supporting files from the workshop IDE to the SD card and until now they are read in the screen without problems. But It would be nice if you could complete the procedure including extra steps for 1.the creation of the unused partition at the start and 2. how to define the maximum cluster size.

                    It would be even better if RMPET could work in all conditions, so I do not have to use the alternative. It is quite annoying to be stopped by failures in tools that used to work.

                    Best Regards


                    Comment


                    • #11
                      We have a lot of Win10 users that don't have this issue. The change that 'creates' it was in Windows 8. Since it is Microsoft that has made a change to prevent apps from issuing write sector commands in certain circumstances their is not much we can do until they document just how this change can be circumvented, and I have a feeling they will not be doing that anytime soon.

                      So at the moment we need to ensure that this is the issue you are having as maybe it is another issue.

                      All of our Industrial cards are now shipped partitioned and formatted correctly.

                      Are you getting your cards from elsewhere? If so, what make and model are they?

                      Also, check your antivirus settings to ensure it does not have 'boot sector protection' or similar turned on. Also check the logs to see if anything is being logged. What product is it?
                      Mark

                      Comment

                      Working...
                      X