Announcement

Collapse
No announcement yet.

gen4-4DCAPE-50T on BBB, Display works but no touch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • gen4-4DCAPE-50T on BBB, Display works but no touch

    I have a new gen4-4DCAPE-50T, HR Rev 2.1, with BBB 4DCAPE adapter, on a new BBB Wireless.
    Out of the box, the display doesn't work at all, but after updating BBB to the latest Debian image, "bone-debian-9.1-lxqt-armhf-2017-08-31-4gb.img", the display works fine, showing the LXQt desktop, and can be used with a USB mouse. The backlight brightness can also be changed as per the gen4 datasheet.
    But there is no touch functionality at all.

    For info, I found a suggestion to "modprobe ar1021_i2c" at a command prompt, and this did enable the touch, but the Y was inverted, and it didn't reach the left/right edges of the screen.
    I also see that there should be a calibration program available, at Start/Preferences, but this does not exist.

    I understood that this Debian image should support the touchscreen, so is there some basic configuration missing ?

    Thanks

  • #2
    Hi PaulB

    The images from Beaglebone are going through some sort of transition and they introduced some problems it seems.

    If you do the following this should make it work for BBB, BBB Wireless and BBG

    load and install this image onto SD card:
    Once loaded, do the following to download a kernel patch which they wrote to fix some of the problems they introduced.

    wget http://rcn-ee.online/builds/linux-im...ross_armhf.deb
    sudo dpkg -i linux-image-4.9.63-ti-r78.2_1cross_armhf.deb
    sudo reboot
    I have sent them a reminder email to see how far away the latest official release is going to be with these fixes.
    Also, they mentioned the calibration program was removed on later releases for some reason, due to it being unstable. So we wait for an updated solution on this too.

    The Y Axis touch inversion came about after the 2nd Oct 2017 release, so before that it was OK.
    This release seems to work correctly, touch is correct and it also features the touch calibration program. This one seems to write itself to eMMC - Just FYI.
    Sadly all software releases are outside of our control, but hopefully things become stable with the releases again.

    I hope this helps
    Regards
    James

    Comment


    • #3
      Hi James

      Many thanks for the information.

      Please keep us updated if possible, on any progress that you know about with the next official BB release.

      For info, your link to the "blank-debian-8.9" image fails with no file present. However, as you say, lets hope that a stable image is released soon which resolves these issues.

      Best regards

      Comment


      • #4
        Hi James

        I have come back to this, and tried your suggested kernel patch.
        This does enable the touchscreen, and it does fix the Y axis being inverted.
        So it is almost usable, but it still does not reach the left/top/right edges of the screen, just enough to make it impossible to select menu items, etc.
        There is still no calibration program available under Start/Preferences.

        Is it possible to edit the touchscreen calibration parameters manually, I imagine they are stored in some config file somewhere ?

        Regards
        Paul.

        Comment


        • #5
          Good day Paul B,

          I believe the Touchscreen calibration sequence activates when you log-in to the BBB as root as experienced by other customers. Can you give this a try? This was the source of my statement: https://groups.google.com/forum/#!searchin/beagleboard/touch$20calibration|sortate/beagleboard/ORZ10t-ooMU/pSdgszo7CwAJ

          This user used the testing image from Robert C Nelson: https://rcn-ee.net/rootfs/bb.org/tes...1-01/lxqt-4gb/ you can download the file "bone-debian-8.10-lxqt-4gb-armhf-2018-01-01-4gb.img.xz"
          Last edited by Mark Kevin; 15th January 2018, 11:49 AM.

          Comment


          • #6
            Hi Mark

            Thanks for the info. I had already tried logging in as root user (I had noted it some other post), but it did not start any calibration sequence, and there is no calibration program in the LXQt desktop menu.

            I am running Debian 9.1 2017-08-31, and I don't really want to go back to Debian 8.1, but I have saved a copy of the image from your link, and I will try it when I get some time for this.

            I hope that Beagle make a new image available, with this all sorted out, before I get round to it...

            Regards

            Comment


            • #7
              Hi PaulB,

              We have informed the BBB moderators about the missing touchscreen calibration.
              They provided us the patch instruction as provided by Sir James to you earlier.

              Then I found the testing image on Robert Nelson's testing image server which coincides with the BBB google group post regarding the touch calibration.
              This is actually the latest testing image, but I am not sure if Robert Nelson used an older Debian image (the 8.1) at the bottom of the latest testing image.

              In the link, it says there "Index of /rootfs/bb.org/testing/2018-01-01". We will try to get in touch with the BBB moderators if they can provide us an image with the fix anytime soon.
              I also tried the latest image from the link, the touch is better and not inverted, however, I still cannot find the touchscreen calibration.

              Comment


              • #8
                debian@beaglebone:~$ uname -a
                Linux beaglebone 4.14.94-ti-r94 #1 SMP PREEMPT Thu Feb 21 23:29:48 UTC 2019 armv7l GNU/Linux
                debian@beaglebone:~$
                This version which is based on bone-debian-9.5-lxqt-armhf-2018-10-07-4gb.img and then apt update displays the lxqt windowing interface on the display but the touch screen calibration program doesn't appear on any of the menus.
                What do I need to apt get from the command line and how do I install it so it runs on boot to calibrate? Should there not be a simple step by step page of instructions to do this from OS release to OS release?

                Comment


                • #9
                  Hi JC,

                  Are you having touch issues with your 4DCAPE? Or are you just looking for the touch calibration for touch check?

                  The latest Debian image for Beaglebone has fixed the “touch-offset” issue that’s present on the previous versions of Debian. The touch values were included in the device tree overlays of the 4DCAPEs in the Debian 9.5 2018-10-07 4GB SD LXQT and this should show a more accurate touch response for 4DCAPEs.

                  May I know the 4DCAPE type that you’re using and the exact Debian version of it? Can you try and reflash your Beaglebone using Debian 9.5 2018-10-07 4GB SD LXQT image?

                  Thanks and Best Regards,
                  Eran

                  Comment


                  • #10
                    Hi Eran.,
                    bone-debian-9.5-lxqt-armhf-2018-10-07-4gb.img.xz is what I used to create the SD card. I've done an apt update and upgrade. Basically following the instructions in Derek Molloy's second addition since his first is now pretty well out of date for a lot of stuff.

                    The 4D 4.3" LCD Cape has (c) 2013, HW Rev 1.11 on the back along with the 4DCAPE-43T. A Debian 7.11 (wheezy) (uname -a ==> 3.8.13-bone82) has the calibration software and I can make my stylus can touch the corners of the screen.

                    The current version from the above mentioned .img returns uname -a ==> 4.14.94-ti-r94 #1 SMP PREEMPT

                    Touching the center of the red circular icon on the bottom left of the display pulls the cursor above and to the right. I can bring up the menu by touching the very bottom left hand corner but it's really off far enough that other locations don't always register or are just unreachable. Or accidentally hit the Chromium button and watch the processor activity rise to 100% for several minutes.

                    Eventually I want to create finger size buttons or sliders for a dedicated user entry screen probably using QT. Once I figure out how to create a window the exact size of the screen without the window title bar at the top. But that's the question for another timer and perhaps a totally different forum.

                    For now I'd like to be able to put the LXQT based LCD touch screen adjust application in perhaps the Preferences or System Tools tab. Or even be able to launch it from the command line via the puTTY 192.168.7.2 connection.
                    Thanks
                    John


                    Attached Files

                    Comment

                    Working...
                    X