Announcement

Collapse
No announcement yet.

GTX issues & Programming issues with Arduino

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • GTX issues & Programming issues with Arduino

    Hi there,

    I am having a few problems, one of which is not being able to control my program through GTX.

    First off I would like to ask why after compiling and building a program in 4D Workshop's Visi-Genie to my display through Flash that when I go to load an example strictly from the arduino (BigDemo.ino) the display gets stuck on "drive not mounted" blinking? Straight out of the box I was able to connect the Arduino Adapter Shield Rev 2 to my Arduino Uno and hook up the uLCD-32PTU to it and download the "BigDemo" arduino code through the Arduino IDE and it successfully loaded and ran on the uLCD-32PTU.

    I have loaded the example Visi-Genie program from the app note "4D-AN-00001_R_1_01" and it works perfectly fine if I was using JUST the display to control the trackbar. I have switched to the BIGDEMO example given and it is the same problem. I have it loaded on my uSD card and Form0 is on my display, but when I try to use GTX to switch between Forms all GTX does is report the command sent through Set or Query in the message area with NO acknowledgement or ACK back. It doesn't even give me an error message to state that the display didn't receive what is being sent. I've gone through several of the AppNotes to search for a possible cause to this, but I can't seem to find anything that fixes the issue.

    My other problem is with my Arduino Uno using an example program again. I set up the Cooling Gauge example exactly as outlined for the 4D Workshop and my Display along with the file provided to be loaded on the Arduino. The problem I have with this is that the arduino is not controlling any of programmed gadgets on the uLCD-32PTU.

    Please let me know if you have trouble understanding a portion of this post. I did my best to explain in words what is going on without writing a book.. lol.


  • #2
    Hello

    Welcome to the forum.

    You explained your problem well and it seems you are not getting any comms to the display. The comms to program the display seem to be working as the example Visi-Genie program from the appnote worked fine but wasn't reliant on comms from the Arduino. You can check your Genie comms settings by clicking on File then Options and then the Genie tab. When using GTX you should be using COM0 and check the baud rate is the same as in GTX.

    I hope this helps

    Best regards

    Paul

    Comment


    • #3
      Hey Paul,

      Fixed that portion! The default settings under File>Options were set at 115200, whereas I was programming with 9600. I think they were clashing or something preventing me from communicating. Nonetheless, I sorted out the comms for that issue. Now the arduino example "genieArduino_Demo" controls the Visi-Genie program on the display while they are connected.

      My other issue though.. When I first hooked up the display to the Arduino straight out of the box and programmed the BigDemo from the Picaso_Serial_4DLib examples it worked fine. But ever since I used Visi-Genie to program the flash on the display it will not run that same Arduino example, it is running from the programmed flash of Visi Genie. Is there a way to revert the flash back to what it was when I first took it out of the box? I have tried to fix this by loading the PmmC I acquired from 4D, but with no luck.

      Comment


      • #4
        Hi,

        Glad that worked out for you,

        Your second issue can be resolved by reflashing the Serial SPE onto the display. As you have used Visi-genie it has replaced the Serial SPE. To get this back youl will need to start a new project choosing your display and then chossing the Serial programming environment. Once this has opened, click on the Tools tab and then SPE Load. This will put your display back to when you first powered it up.

        I hope this helps

        Paul

        Comment

        Working...
        X