Announcement

Collapse
No announcement yet.

4DPi-24HAT - USB stopped working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4DPi-24HAT - USB stopped working

    Hi,
    I have burned on SD card the newest kernel of Raspbian (13 March 2018) and I did apt-get update and upgrade. I have also mounted pendrive and I've updated fstab to mount it on each boot. Everything was working smoothly.

    Next I've installed 4DPi-24HAT kernel according to instruction on your website (available version: Kernel 4.9.35). As a result I have "bricked" my Pi. It seems that USB is not working at all. Keyboard is not reacting on any key press, mouse laser is off and mouse is not active, I have a message that it is not possible to mount SDA1 (pendrive).

    So I tried with older Raspbian Stretch (July 2017) and I've repeated the procedure but without apt-get update and upgrade. Your screen started to working fine and Pi was working fine as well.

    Nevertheless I was forced to do apt-get update/upgrade because I needed some packages. And I bricked my Pi again...
    Please let me know if you plan to add support for the newest Raspbian?

    update:
    I have Pi v3

    update 2:
    I have tried with a new Stretch image (march 2018) again. I did not mount any pendrive this time - keyboard and mouse working fine. Next I updated Raspian with your driver and results is that display is working correctly, but USB is not working at all. My keyboard and mouse are dead.
    I tried with:
    https://www.4dsystems.com.au/downloa...59_v1.2.tar.gz
    and
    https://www.4dsystems.com.au/downloads/4DPi/All/gen4-hats_4-9-35_v1.0.tar.gz

    I tried with different keybord and mouse with no success.

    During boot phase I can see an error (?) message: "FIQ is disabled due to missing regmap".
    Last edited by jakub; 20th March 2018, 09:14 AM.

  • #2
    If you do not plan to support the newest Raspian Kernel may you please let me kow what is the newest combination of:
    - Raspbian kernel
    - 4DPi-24HAT kernel
    which is working correctly?

    Comment


    • #3
      Hi Jakub,

      Good Day.

      Welcome to the forum.

      You can use the Raspbian Stretch 2017-11-29 image and 4D kernel gen4-hats_4-9-59_v1.2.tar.gz for now.

      Hope this helps.

      Best Regards,

      Comment


      • #4
        Thank you very much for help

        Comment


        • #5
          Hi Jakub,

          Good Day.

          We have a new gen4-4DPi Kernel gen4-hats_4-9-80_v1.1.tar.gz
          which is for new Raspberry Pi image release 2018-03-13. You download it from the link below.

          http://www.4dsystems.com.au/download...80_v1.1.tar.gz

          Best Regards,

          Comment


          • #6
            So far working good, thank you.

            Comment


            • #7
              jakub @frsantiago, did you test drivers with Raspbian 2018-04-18?

              Edit:
              I have tried it but I have got following errors (images in attachment)
              Attached Files
              Last edited by ivan; 14th May 2018, 10:45 PM.

              Comment


              • #8
                Hi Ivan,

                Welcome to the forum.

                We have a new Kernel for gen4-4DPi Displays for Raspbian 2018-04-18.
                You can download it from the link below and try on your 4DPi-24HAT.


                http://www.4dsystems.com.au/download...34_v1.1.tar.gz

                Hope this helps,

                Best Regards,

                Comment

                Working...
                X