No announcement yet.

gen4-4dcape-70ct-clb not working, but cape is loaded

  • Filter
  • Time
  • Show
Clear All
new posts

  • gen4-4dcape-70ct-clb not working, but cape is loaded



    I added a new post far below of how I got the LCD towork with both, Debian 8.6 LXQT, and Debian 8.3 (+ Kernel 4.4.x) LXQT.

    ____________________________________________________________________________________________________ _______________
    ____________________________________________________________________________________________________ _______________

    I tried to get this display to work with my BeagleBoneBlack. It has a Debian image on it, not the newest, but as can be seen in my capemanager slots, it has been found, but is listed as index "-1", doesn't sound good...
    Since this cape is in there without me doing anything, I assume the Debian image must be new enough in general.
    Just installing the newest Debian image and praying it will work is not a viable solution, I need to get this working with the present image.

    "not working" means: I see nothing on the screen, but I can log in via USB-ethernet and list the slots, so the beagle is still fine.
    In another thread I had seen the question whether the backlight works - I don't think it works, I don't see anything from any angle.
    There is no other cape connected to that beaglebone. (I loaded some other overlays for experimenting)
    Power is a 1.5A 5V PSU, and USB is also connected. (I tried with a bigger lab PSU which delivers 2A as recommended, but it never drew more than 0.42A or so between boot and login)
    There was a setting in the uEnv.txt: video=HDMI...., which I removed & rebooted, did not help.

    Any idea what could be wrong?

    0: P----- -1 4D 7.0 LCD CAPE - 4DCAPE-70CT,00A1,4D Systems,BB-BONE-4D7C-01
    1: PF---- -1
    2: PF---- -1
    3: PF---- -1
    4: P-O-L- 0 Override Board Name,00A0,Override Manuf,EBB-GPIO-Example
    5: P-O-L- 1 Override Board Name,00A0,Override Manuf,BB-UART2
    6: P-O-L- 2 Override Board Name,00A0,Override Manuf,BB-UART4

    Note: the "EBB-GPIO-Example" overlay only uses pins which were marked as free GPIO pins by default, on the colorful pinout chart on Derek Molloy's site.

    #1 I disabled the other overlays, such that only line "0" of the above slots has the entry as seen. Nothing on screen, so it probbaly was no pin config problem.

    #2 dmesg shows this line: [ 5.133600] bone_capemgr bone_capemgr: loader: failed to load slot-0 BB-BONE-4D7C-01:00A1 (prio 0)
    I saw no other entry that was obviously related to this. (oh, besides the line saying it found it, of course, prior to its failure to load: bone_capemgr bone_capemgr: slot #0: '4D 7.0 LCD CAPE - 4DCAPE-70CT,00A1,4D Systems,BB-BONE-4D7C-01')

    #3 Just to know, I booted from the newest Debian image from SDcard without installing, and the display does not show anything either, I also see no backlight shining through anywhere. BUT the BB-BONE-4D7C-01 overlay is in slot #0, not "-1", and the dmesg log shows dtbo to be "loaded".
    So my older Debian has at least two problems, and the newest at least one - as it loads, but nothing to see. (if there is a possibility to fix the failue to load on older Debian, I'd prefer that, though. All sorts of things for my programs won't work anymore on the newer Debian, they keep shifting things around)

    #4 I noticed a newer Debian image is out (9.4 vs. 9.3), also, I had only the console version on the SDcard (which should not matter to see *somethig*, but anyway), so I tried that. Same result.

    Silly question: Could the hardware simply be broken in a way that produces the described effect, i.e. nothing visible while, nontheless, the BBB can read the display's presence & hence load the overlay? Has it occured that e.g. the backlight was dead?
    Last edited by sktprin; 7 July 2018, 12:06 AM.

  • #2
    Hi sktprin, welcome to the forum.

    What did you mean by “Power is a 1.5A 5V PSU, and USB is also connected”?
    Did you mean that you use a power source that has a USB jack?
    If so, there will be no power driven to the display since USB jack will not draw its power to VDD_5V pin/s where the display is getting its power from.
    To address this, kindly refer to section 8 - Power Source for 4D CAPE of this datasheet.

    If the power source is from the DC jack, kindly check the voltage output of VDD_5V pin/s of the cape. If there is no output reading, most probably, this the reason why the display is not powering up.

    Hope this will help.



    • #3
      Hi, it is powered from DC jack, but USB is also connected for USB-ethernet. VDD_5V measures 5.02V, and I left the solder bridge SB1 as is, so the middle blob measures the same.

      With the Debian 9.3 IoT image (text only), I now actually saw light coming out of the slit on the center of the bottom of the LCD case, where you can also see the brown "internal" flex cable going around the metal chassis. Nothing to see on screen, though.
      The Debian 9.4 LXQT image doesn't boot that far when the display is connected, apparently. It does boot if it's not connected. It does not boot far enough to be able to connect, right now I'm soldering wires to the inaccessible (cape is in the way) debug UART on the beagle...
      So I'm looking at the serial output when booting Debian 9.4 LXQT image. After some mentions of cape loader, i says:
      "[drm] Cannot find any crtc or sizes"
      After several *minutes*, it says "random: crng init done", nothing else in between, so it's struggling.

      In this thread:
      the post from "Nov 22, 2017 2:45 PM" says:
      "The "Cannot find any crtc or sizes - going 1024x768" message is caused by unsuccessful attempt to obtain no one video display resolutions.
      A comment in the source code assumes probability of problem with display connection.

      Not sure what they mean by "display connection". I re-plugged the white flex cable and looked with real sharp eyes that they are in straight and as far as they go, and fastened by the cable sockets... no help.

      And trying the freshly soldered debug UART now with the other image, Debian 9.3 IoT, which does at least switch the backlight on at some point, I see this output:

      [ 0.000926] clocksource_probe: no matching clocksources found
      [ 1.377164] wkup_m3_ipc 44e11324.wkup_m3_ipc: could not get rproc handle
      [ 1.622724] omap_voltage_late_init: Voltage driver support not added
      [ 1.630081] PM: Cannot get wkup_m3_ipc handle
      [ 1.935135] bone_capemgr bone_capemgr: slot #0: '4D 7.0 LCD CAPE - 4DCAPE-70CT,00A1,4D Systems,BB-BONE-4D7C-01'
      [ 1.972324] bone_capemgr bone_capemgr: slot #1: No cape found
      [ 2.004578] bone_capemgr bone_capemgr: slot #2: No cape found
      [ 2.035576] bone_capemgr bone_capemgr: slot #3: No cape found
      [ 2.065450] pinctrl-single 44e10800.pinmux: pin PIN40 already requested by 0-0070; cannot claim for panel
      [ 2.081558] pinctrl-single 44e10800.pinmux: pin-40 (panel) status -22
      [ 2.094115] pinctrl-single 44e10800.pinmux: could not request pin 40 (PIN40) from group pinmux_bb_lcd_lcd_pins on device pinctrl-single
      [ 2.118210] panel panel: Error applying setting, reverse things back
      [ 2.135938] tilcdc 4830e000.fb: no encoders/connectors found

      What gives?
      It's an unmodified image, as downloaded. And 9.4 does worse than 9.3.
      Last edited by sktprin; 22 June 2018, 08:07 PM.


      • #4
        Hi again,

        Kindly test first your setup in image version 1-28-18 as well with the newest image (refer to this link) in order to make sure that there is no problem with hardware. Those images are tested to work with the gen4-4DCAPE with BBB.

        If this still doesn’t work, you can raise the problem as a ticket in



        • #5
          I tried with the LXQT image from 1-28-18, it does not switch on the backlight.
          Thanks, I'll do that.


          • #6
            For those wanting to get this to run with older Debian images:

            So I got the new display now. It showed different kind of errors than the presumably broken display, so it's a good sign in some way
            With newest Debian images, like 9.4 or 9.3, with LXQT. from the beagleboard site, I could not get this to work.
            But I did with older versions - more details below.

            But first some pointers to possible causes of the above:
            So I got a kernal error message, seen in serial console (uart0), which, if you have the cape on your beagle, need to solder wires to the pins to e.g. some external piece of pin header where you can plug our usual serial adapter wires into - from the underside of the board, soldering on the header pins of the debug uart connector of the beagle.

            This kernel error message and google lead me to this thread:
            It says at some point: "issue been resolved. clks were enabled in u-boot, but not in kernel"
            I cannot say how much this is really related, I don't really understand what those things are, it's pretty thin evidence
            It lead me to think that maybe my Beagle's U-Boot is too old for the newer Debian images.
            The kernel crash only happens with the LCD connected, though. So maybe a combination of 3 things: uboot version, debian image version, and presence of the display.

            Since the procedure of upgrading the uboot seems rather elaborate:
            I elected not to do that for now.

            So I tried to get this to work with an older Debian image. At first, because I thought there as evidence my version so far is *too* old for several reasons, I tried it with a few, until I founmd oe where initially at least it started in command line with the LCD on! Although it was all LXQT images... but hey, progress.
            That was the debian 8.6 lxqt image,l as found here under "older images" or so:

            I tried a lot of things, but those two added lines to the /boot/uEnv.txt here did the trick:
            • uboot_overlay_addr0=/lib/firmware/BB-BONE-4D7C-01-00A1.dtbo
            • dtb=am335x-boneblack-emmc-overlay.dtb
            Note that that's for my display. I assumed "4D7C" would stand for 4D systems cape, 7 inch, Capacitive, as there were also "R" and "N", which I guess means "resistive" and "no touch", and it works. It seems the display needs calibration, though :D It's a bit off. Need to find out how that works.
            Hints at those things here:

            Now, I tried whether those tricks would also do something for the Debian 9.4 image, not with high hopes, as the errors looked different.
            And indeed, the 9.4 did not work anymore becasue that dtb does not exist.
            But through that accident, l something interesting happened:
            As the bootom from SDcard did not work, it somehow booted alternatively from eMMC, *but* somehow retained some of the information from the SDcard 9.ö4 image's uEnv.txt, and thus, my old Debian 8.3** on the eMMC also started with LCD and in GUI desktop - but this did not work without SDcard inserted :D

            ** Note, however, that, previously, I performed the following steps on that Debian 8.3 installation on the internal flash:
            • install slightly newer Linux kernel with version: 4.4.13 ("4.4.x")
            • install bb-overlays
            As both shown here:
            (I used the -ti- images without the "-rt-", as that would be real-time kernel, not best choice for generic desktop usage)
            The Beagle must be connected to the internet e.g. via ethernet port. If you get complaints about not finding the web adresses to fetch the install packages from you may need to add a nameserver. There is a better, permanent way, which I forgot alas, this only lasts until reboot: sudo nano /etc/resolv.conf --> add the line "nameserver" to add google's nameserver.

            The bb-overlays, also containing the LCD overlay, were not present on that old version.
            Also, I have a suspicion that the "uboot_overlay_addr0=....." line would not work with the original kernel of debiamn 8.3, as it doesn't come with a comment for that in the uEnv.txt, but in newer versions it does. I haven't checked that and no time to try the minimum required steps to make this work.
            But those steps did work for me.
            Last edited by sktprin; 7 July 2018, 12:07 AM.