Announcement

Collapse
No announcement yet.

Characters wrong size and mirrowed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Characters wrong size and mirrowed

    IOD 9 TH: I have previously seen the display work with the WiFi Scan example, However, after installling the WS 4 on my new pc, the same example shows the characters in wrong size and mirrowed. I can change the txtsize to bigger, but I cannot get the normal size 1. I tried with my second display, when powered on, it showed the 4D splashscreen OK, but after programming the example, the same problem occur. Anyone seen this and have the solution?
    Attached Files

  • #2
    Hi,

    We don't actually have a Wifiscan demo for the IoD-09TH, we only have a wifiscan demo for the the gen4-IoD's. The gen4 IoD has a different screen driver to the IoD-09TH. If it is the WifiScan demo for the gen4-IoD then it won't wotk with the IoD-09TH. There is a demo which includes a WifiScan part for the IoD-09TH in the examples folder of the GFX4dIoD9 library.

    I hope this helps

    Best regards

    Paul

    Comment


    • #3
      Hi Paul,
      Thanks, that make sense :-)
      However, when I try the IoD9TH demo, I get this error:

      Arduino: 1.8.5 (Windows 10), Board: "4D Systems gen4 IoD Range, 80 MHz, 115200"

      Archiving built core (caching) in: C:\Users\mig\AppData\Local\Temp\arduino_cache_584222\core\core_esp8266_esp8266_gen4iod_CpuFrequency_ 80,UploadSpeed_115200_1d9684ef660603d4e4e8dc6794746366.a
      Sketch uses 370796 bytes (85%) of program storage space. Maximum is 434160 bytes.
      Global variables use 46840 bytes (57%) of dynamic memory, leaving 35080 bytes for local variables. Maximum is 81920 bytes.
      error: Invalid argument or value after {upload.erase_cmd} (argument #8)
      An error occurred while uploading the sketch

      This report would have more information with
      "Show verbose output during compilation"
      option enabled in File -> Preferences.

      This is the same for both of my displays. Are they damaged?

      regards
      Poul

      Comment


      • #4
        Hi Poul

        Thank you for the information. Would it be possible to send me your boards.txt file which you can find in this directory on your PC.

        C:\Users\<your user name>\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\2.3.0 or the version number of your ESP8266 core.

        Best regards

        Paul

        Comment


        • #5
          SOLVED ! Apparently the GEN-4 program blocked the bootloader. When pressing the reset button on the 4D-UPA during compilation, and release the button thereafter, the IoD9 demoprogram uploaded correctly. Hereafter there was no problems with upload. The second display was solved likewise. puyh. :-)

          Comment


          • #6
            Hi,

            Thanks for letting me know and great that you fixed it. This will certainly help others in the same position.

            Best regards

            Paul

            Comment


            • #7
              yup it was informative discusssion

              Comment

              Working...
              X