No announcement yet.

4dpi 32 raspberry pi model b+ No network after hat configuration

  • Filter
  • Time
  • Show
Clear All
new posts

  • 4dpi 32 raspberry pi model b+ No network after hat configuration

    Hello, after installing hat on pi 3 model b+ on Raspbian strech desktop no network interfaces is shown. When I click on wireless icon task bar it says no APs found and keeps searching for APs.

    I installed Raspbian strech 3 times everything was working till I followed the lines on hardware version 2 steps from pdf and installed the hat tar and untarred it and booted. Eth0 wlan0 got disabled also no network devices found. I tried raspi-config entering network configuration manually but no success.

    Also with regular version after hat installation both hdmi and hat doesn’t work.

    It works as intended on raspi model 3 but not on 3 model b+.

    Could you help?
    Best regards,

  • #2
    Hello Gomania,

    I have tried the latest kernel version with the latest Raspbian OS on a Raspberry Pi 3 B+.
    However, I didn't encounter the issue that you have mentioned.

    Are you using the latest kernel version?

    Copy the file on your RaspberryPi and extract it using the command:
    sudo tar -xzvf gen4-hats_4-14-34_v1.1.tar.gz -C /
    I hope it helps.


    • #3
      Hello John,
      Thank you. Now it is working.

      There is still question in my mind, wondering, Where should I check the latest version from?

      Because I tried to follow the link from product web page (4DP-32) ->

      which redirected me to: 4d-hats_4-9-35_v1.1.tar.gz on

      Then it showed me that the kernel which I was looking for is not there but has multiple choices and I follow the link from there to because there was no file named: 4d-hats_4-9-35_v1.1.tar.gz.

      This is also the same on product PDF version 2:
      Page 6 of 18 Item 8) $wget DPi/All/4d-hats_4-9-35_v1.0.tar.gz

      Finally I ended up with version: 4d-hats_4-9-35_v1.0.tar.gz

      Leaves me with the question: Where should I check the latest version from? If it is not the web page or product manual.

      Many thanks,



      • #4
        Hello Gomania,

        Currently we are updating the datasheets and links to put the correct kernel image package.

        For the meantime, you can check the latest kernel package through visiting the product page of our newest 4DPi displays:
        Software Packages -> 4DPi Kernel Package.

        This is also included on the datasheet.
        Documentation->gen4-4DPi Datasheet

        Best Regards