No announcement yet.

Stuck in command lines while connected to 4DCAPE43-T (LCD screen)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Stuck in command lines while connected to 4DCAPE43-T (LCD screen)


    I've been spending the last while trying to get my 4DCAPE43-t LCD screen working with the BBB. When attached to the beagle and powered on, its supposed to look something like this: In my case, the onboard LEDS turn on, the linux logo displays but instead of going to the expected display, it goes to a command line-esque interface (exactly like a putty window). A JPG of this is attached.

    So far I've flashed the board with a microSD containing a newer image of debian and I previously have been messing around with the board through putty (connected via USB). How do I get the LCD screen to display the desired interface? Is the issue with the boot options? Am I missing something with the software?
    Attached Files
    Last edited by Jeremy P; 26 July 2018, 12:44 AM.

  • #2
    Hi Jeremy,

    It seems that the image that you’re flashing is of no desktop environment type. Can I ask for the exact image that you’re using so I can try it here on my end?

    You may also try the latest image with desktop from .

    Best Regards,


    • #3
      Hi Eran!

      I'm not sure about the exact image it is but I'm now aware that it I should be using a LXQT Version. So I installed the latest one off the website you provided (9.4 lxqt) onto an SD card an booted the latest one from there. What I get now is a backlit black screen as the board turns on (see attached). The LEDS on the LCD panel are both solid on, and beagle's normal heartbeat is on. The screen does not display any linux logo/ user interface. Also attached is a picture of the desktop view (when the screen is disconnected) of accessing the beagle via PuTTY. I cannnot connect to the beagle via SSH when the LCD screen is connected. Version of the image is shown (Debian 9).

      Is there anything I can do to make this work?

      EDIT: Turns out I'm using a gen4-4dcape 43-t, does this make any difference?
      EDIT2: No luck with older version of debian lxqt
      Attached Files
      Last edited by Jeremy P; 25 July 2018, 05:26 AM.


      • #4
        Hi Jeremy,

        Logging in to Beaglebone via Putty initially shows Command Line Interface, so that’s normal; and 4D-CAPE-43T means that it is a Resistive Touch Display, which supports Desktop Environment Applications.

        Without connecting the cape, can you run this command and give me the results:
        Please note as well from the Section 3.2.5 of the datasheet,
        Connect a 5V Supply to the DC Jack of the Beagle Bone Black. It is recommended to use a 2A supply to ensure sufficient supply.
        Can you try another power source (i.e. DC Jack) to boot your display?

        Best Regards,


        • #5
          Hi Eran!

          The results of the code you game me are attached. Using another power source leads to the same result of a backlit black screen....

          I'm going to see if a very old version of debian LXDE works. I will perhaps try using a FTDI Friend chip (from adafruit).

          Any ideas as to what's going wrong? I'm near my wit's end on this.

          Attached Files


          • #6
            IT WORKS NOW! Shoutout to Robert Nelson on the Beaglebone Google Group! (see our conversation here:!

            I used the latest distribution of debian (9.4) (NOTE: you need the version that allows graphical desktop which is LXQT). I flashed it onto an SD card using win32 software. Plug the SD Card and boot the beagle.

            By his instruction, I typed into my PuTTY terminal with the screen disconnected (connected to computer via USB):
            sudo /opt/scripts/tools/
            Which outputted this:
            dogtag:[ Debian Image 2018-06-17]
            bootloader:[microSD-(push-button)]:[/dev/mmcblk0]:[U-Boot 2018.03-00002-gac9cce7c6a]:[location: dd MBR]
            bootloader:[eMMC-(default)]:[/dev/mmcblk1]:[U-Boot 2015.04-00001-g96581e0]:[location: dd MBR]
            pkg check: to individually upgrade run: [sudo apt install --only-upgrade <pkg>]
            groups:[debian : debian adm kmem dialout cdrom floppy audio dip video plugdev users systemd-journal i2c bluetooth netdev cloud9ide gpio pwm eqep admin spi tisdk weston-launch xenomai]
            cmdline:[console=ttyO0,115200n8 root=/dev/mmcblk0p1 ro rootfstype=ext4 rootwait fixrtc coherent_pool=1M net.ifnames=0 quiet]
            dmesg | grep pinctrl-single
            [    1.047141] pinctrl-single 44e10800.pinmux: 142 pins at pa f9e10800 size 568
            dmesg | grep gpio-of-helper
            [    1.048716] gpio-of-helper ocp:cape-universal: ready
            Then Robert said:
            Your old version of u-boot in the eMMC is blocking overlays from
            working properly..

            Just run:

            sudo dd if=/dev/zero of=/dev/mmcblk1 bs=1M count=10

            and shutdown/reboot..

            Then u-boot will auto-detect the LCD and pass the proper overlay to
            the kernel. You should see the LCD come up early with a linux mascot
            showing up..
            I powered down the beagle and reattached the screen.

            And now it works!

            Thanks for the help Eran!. I hope my 4 days of confusion can help other users in the future.


            • #7
              Hi Jeremy,

              Good to hear that you’ve made it work and thanks for sharing the procedure.

              All the best for your project!

              Best Regards,