Announcement

Collapse
No announcement yet.

White Screen

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • White Screen

    I have just received my GEN4-IOD24T and followed the various tutorials to get everything set up with Arduino. The examples seem to compile and upload correctly but I always get a white screen. Serial, WIFI and Touch are all working fine so the program seems to be functioning but not the screen. If I set the backlight to false, the screen goes black.

    Please can someone advise me on what to do to troubleshoot this issue? Or have I received a faulty screen?

  • #2
    Hello Chrisv_s,

    Can you tell us which example did you try with the dislay module?
    Did you select the proper board in the Arduino IDE (4D Systems IoD Range)?

    Are you running the latest ESP8266 Arduino library core, there might be
    some changes in the flash memory type in the boards.txt file in the library in the latest release.

    To check the flach memory settings open the board.txt file located at your arduino local files:
    C:\Users\<User>\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\<version>

    Then check the flash memory preferences for the 4D Systems gen4 IoD Range: gen4iod.build.flash_mode=qio
    you can try setting it to gen4iod.build.flash_mode=dio. This is compatible with all the IoD hardware version.

    Lastly, please check if the display flex Cable (orange) is properly latched at
    the back of the controller board.

    If none of that resolve the problem you can contact our support team on this link
    https://www.4dsystems.com.au/support.
    Hope it helps.

    Best regards,
    Bern
    Last edited by bernadette; 29th August 2018, 12:31 PM.

    Comment


    • #3
      Thanks Bern. I ran the TouchTest4D example first and yes, did have the board correctly selected. It seems to have written ok and I modified the code to write a serial response when touched which also worked fine, just nothing visually showing on the screen.

      I will run through your troubleshooting tips above later and report back.

      One thing I should have mentioned is that the screen was totally white when I plugged it in for the first time...should there have been some kind of holding logo or something for a brand new unit?

      Chris
      Last edited by chrisv_s; 29th August 2018, 11:13 PM.

      Comment


      • #4
        Hi Bern,

        I have gone through the above steps and checked that I have the right flash memory settings. It seems to flash ok so not sure this is where the problem lies.

        As far as I can tell, the orange cable looks firmly latched on to the control board.

        I'll contact support now and find out what to do/try next. It would be good to understand if I should have seen a welcome screen/logo when first plugging in the device or if it is normal for the screen to be white at this stage.

        Chris

        Comment


        • #5
          Update:

          Paul from support got in contact immediately and asked me to try carefully unlatching the connector for the display cable and make sure that the cable is all the home and then re-latch the connector. This worked and I now have a working screen.

          Thank you to Paul, Bern and the team for their fantastic and incredibly quick support with this issue.

          Comment


          • #6
            Hello Chris,

            Your welcome, if you have more questions you can always reach our forum.

            Best Regards,
            Bern

            Comment

            Working...
            X