No announcement yet.

4D-UPA will not connect

  • Filter
  • Time
  • Show
Clear All
new posts

  • 4D-UPA will not connect

    Last week I purchased a SK-gen4-70DCT-CLB-SB it came with the 4D-UPA.

    I'm trying to get something-anything to happen with the display, and am getting quite frustrated with it.

    I've gone through the quickstart guide, and connected the FFC to the display, as well as the 4D-UPA. Then connected the 4D-UPA via microUSB to my computer. the UPA reads in my devices as a port, and in Workshop4 I can select said port (under the comms tab) But I've not been able to have workshop4 connect to the display at all. When I connect the microUSB the display backlight flashes ~2hz and not very bright at all. Every time I try to connect the 4D-UPA LED will flash once as I initialize the connection (click the red button) and once right as the screen updates saying "Device is not responding"

    First I thought it was my install. So I uninstalled, and reinstalled, including drivers. Still the same.
    Then I thought maybe it was my computer hardware. Went to a different computer (laptop) installed Workshop4, Still the same.

    on each computer i've used multiple different USB's, and even changed out the FFC thinking maybe that had the issue.. Everything I try gives me the same damn result.

    At this point I'm fearing that the $250 display is just a damn paperweight. What am I doing wrong?

  • #2

    Welcome to the forum!

    Basically, Larger display consumes a large amount of current than a smaller display.
    Have you tried testing it with different USB cord? Some USB cords cannot pass higher currents.

    Please, let me know if it works.

    Best regards,


    • #3
      I have used multiple Cables, multiple ports, powered hubs, direct to the computer USB's. all give the same result.

      I have even tried powering it with a 2A capable supply (normally for Raspberry Pi's) and the display still just flashes (though I can't confirm lack connection because of the nature of the power supply)


      • #4

        Sorry to hear you are having problems.

        You can raise your hardware issue to our technical support for a more thorough analysis of your issue, that can be found here:

        Best regards,