No announcement yet.

Problems with the driver (Sk-4duino-24)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with the driver (Sk-4duino-24)

    I am having trouble with the USB driver of the 4duino.
    I just downloaded from the 4Duino's page, and installed at the device manager. But i can't load any project inside it. It is frozen at the inicial screen ("4D systems pty Ltd..."). When I load any project, the screen turns off, and returns to beginning.
    Btw, the only software that recognize the board it's the Arduino IDE. Workshop4 keep saying: "Device not responding".
    I am using a Windows XP system, and I already tried to reinstall all IDEs (Arduino IDE first).
    Any help?

  • #2

    Workshop4 keep saying: "Device not responding".
    Are you refering to this?

    Click image for larger version  Name:	Capture.PNG Views:	1 Size:	5.9 KB ID:	66588
    If so, then the red button will not change coulor until you access the Picaso chip directly as stated on the 4Duino-24 Datasheet.

    Put simply, the button only works for our core display modules.

    Are you sure you've followed all the set-up instructions on the datasheet?

    Are you receiving any error message from the Arduino IDE?
    Last edited by michael_4D; 18 January 2019, 02:29 PM.


    • #3
      Yes, i am refering to this. So the only way to change that button color is using the uUSB-PA5? I tried and it works. But when i return to the regular µUSB , the button return to red.
      I think I followed all the set-up instructions, but i will check again.

      Even in the "Arduino Comms" section, still no detecting the 4Duino.

      When using the Arduino IDE, the screen freezes at "Mounting...".


      • #4
        Ok. I think i got it. My SD card don't have the images required from the Workshop4 IDE.