No announcement yet.

Any way to bypass creating support files?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Any way to bypass creating support files?

    Hi, I have a large project with a LOT of video files. Over 1GB. takes about 45 minutes to create the .gci file. I'm fine doing that ONCE, but the IDE wants to do it every time I re-open the software, even though all I have changed is the code, not any of the graphics or any of their parameters. I know nothing has changed in the .gci and I don't want to wait 45 minutes every time I re-open the IDE to continue editing code. Is there any way to tell the IDE not to re-gen the support files and just compile the code?

    This problem is made worse by the fact that every time the IDE gets to a new video, it re-invokes whatever converter it's using and the IDE pops to the top of my PC apps, so whatever I'm doing in another app is interrupted. So basically I can't use my PC for anything for 45 minutes.

    Help! Thanks.

  • #2

    Could you please clarify what environment you're using? Since you've mentioned that your coding on 4DGL, I would assume that you're working with either ViSi or ViSi Genie with a PRO License

    If you're using ViSi Genie, as you may know, there are two compile buttons,
    the right button builds the graphics files only when Workshop detects any change made on the WYSIWYG screen and/or the Object Inspector
    as stated on this Application Note:

    ViSi-Genie Getting Started - First Project for Diablo16 Display Modules

    If you're using ViSi, I found that my program seems to load immediately without rebuilding the GCIs once I've already loaded it successfully.

    In either of the two environments, I would suggest staying away from the WYSISYG pane when modifying your code as even the slightest repositioning of a single widget could result into the tedious process of rebuilding your graphics files.

    Also, May I ask if it's really necessary to use all of those videos? It might be worth considering to reorganize your graphics files in order to have a relatively smaller GCI file

    I hope this helps.

    Best regards,


    • #3
      Thanks Michael for the reply. Yes, this is in Visi with Pro. I'm working with the Goldelox modules.

      I am staying away from the WYSIWYG panel-- not changing anything there, even clicking on anything. I could understand where that would cause a re-compile. That's why the issue is so odd. This happens when I've been away from the computer and have closed the IDE, then say I come back the next day and open it. No matter what, the first time I compile, it rebuilds the cgi.

      And yeah, I'm sure you think I'm crazy for having so many videos. It's hard to describe what I'm making-- basically a video jukebox, so multiple video files are necessary. I'm ok with the large gci, just not with the IDE thinking it needs to re-comp the gci every time.

      Question: is there a way to compile the code from the command like, without using the IDE? Some SCRIPTC command, maybe? I know how to use that to load already-compiled code onto a module without using the IDE, but maybe there's a way to compile from outside the IDE that would bypass the (faulty) GUI logic RE: the gci?

      Let me know what you think, thanks.


      • #4
        OK, quick update on this-- as usual, looks like it was user error. When I click Compile first, then Download, it only sends the code and does not re-build the gci.

        I think that may have been what you were trying to tell me above. :-) In any case, I think we're good now.


        • #5
          When writing in VISI, I have same problem. Once a compile error is made during program editing , it starts rebuilding the gci and asking the update, even without touching the WYSUWYG panel.
          It keeps doing that until editing your code is error-free . This is very disturbing. Is there any way to overcome that issue please?


          • #6
            Hi Marcus,

            Welcome to the forum.

            After a successful compile and upload of your program at least once, it will not compile the graphics again. If you are only editing the code without editing the graphics then you can do the option of copying the .4dg and .inc files into another folder. Open the .4dg file in a designer environment. That way there is no chance of touching the WYSIWYG area that can cause an update. That's why we always suggest completing the graphics design first before coding.

            Hope this helps.

            Best Regards,


            • #7
              Hello Ferdinand,

              Thank you for your fast reply and info.
              Okay for that, copying the 4dg file into another folder. Thats why the problem persists when I try to open the 4dg file separately causing the graphics always to auto-load too.
              But as I am used to work only in VISI environment, coding and changing graphics is continious modified and combined as the design grows. In a separate folder, it can not be done that easy anymore.
              Therefore, I always wished to have a shortcut like CTRL/F9 wich compiles the code but "always" ignores the graphics compile until wanted and effectued with another shortcut logically F9.

              With Best Regards,



              • #8
                What version of Workshop are you using?


                • #9
                  Hello Mark,

                  I use version the latest one.
                  The editor does indeed no graphics compile with shortcut cltrl/F9, but still executes it repeatedly once programming errors were entered in the editor and stops only until all entry errors are solved so this collects a lot of waiting while busy doing debug-compiling.

                  With Best Regards,



                  • #10

                    Can you please add a Skip button to support file progress dialog? I missed one ; and now workshop is rebuilding 2GB of support files for no reason